Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Private window icons in Win 10 doesn't work as expected with Profiles

  • 3 replies
  • 0 have this problem
  • 5 views
  • Last reply by scaleb

more options

I have shortcuts to launch Firefox in two ways, one with no commands and one with the following command: -P "Personal" --no-remote This used to show two separate Firefox icons on the taskbar. Firefox windows opened in each profile would be grouped with the same profile and kept separate from other profiles. With the latest update I still have two icons, the Default profile has a Firefox icon and the 'Personal' profile has a private browsing icon. Even though there are no private windows open. According to latest updates, if I open private windows then they should be grouped with their own icon. However, whether I have Default or Personal profile windows open, Private windows are grouped with their standard browsing windows.

This is on Win 10, Firefox 107.0.1

Any ideas how to fix this? Ideally I would have the standard Firefox icon on both profiles then, to conform with the private window separation update, my private windows would be separated from the standard windows but also from different profiles.

I have shortcuts to launch Firefox in two ways, one with no commands and one with the following command: -P "Personal" --no-remote This used to show two separate Firefox icons on the taskbar. Firefox windows opened in each profile would be grouped with the same profile and kept separate from other profiles. With the latest update I still have two icons, the Default profile has a Firefox icon and the 'Personal' profile has a private browsing icon. Even though there are no private windows open. According to latest updates, if I open private windows then they should be grouped with their own icon. However, whether I have Default or Personal profile windows open, Private windows are grouped with their standard browsing windows. This is on Win 10, Firefox 107.0.1 Any ideas how to fix this? Ideally I would have the standard Firefox icon on both profiles then, to conform with the private window separation update, my private windows would be separated from the standard windows but also from different profiles.

Chosen solution

Eventually solved it by creating a new profile and dropping the --no remote from my shortcuts. Not sure why that helped, but it did...

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Eventually solved it by creating a new profile and dropping the --no remote from my shortcuts. Not sure why that helped, but it did...

Helpful?

more options

You can set this pref to false on the about:config page to disable the extra PB icon on the Windows Taskbar.

  • about:config => browser.privateWindowSeparation.enabled = false

Helpful?

more options

Unfortunately that didn't work in this instance. I should have said in my post. The issue isn't private windows being separate but a separate profile being given a private icon even though it had no private windows open.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.