Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed -- How to bypass?

  • 6 replies
  • 1 has this problem
  • 18 views
  • Last reply by cor-el

more options

Sometimes when I try to use Google Firefox will slap me with the SECURE CONNECTION FAILED page (attached). Which obviously NO!!! It's GOOGLE. I have to reload and reload and reload and reload and it can take absolutely forever to get it to work properly again. Only happens with Google. How do I either fix this or force Firefox to access non-secure websites anyway? There has to be a way to force access regardless of security!

Thank you!

Sometimes when I try to use Google Firefox will slap me with the SECURE CONNECTION FAILED page (attached). Which obviously NO!!! It's GOOGLE. I have to reload and reload and reload and reload and it can take absolutely forever to get it to work properly again. Only happens with Google. How do I either fix this or force Firefox to access non-secure websites anyway? There has to be a way to force access regardless of security! Thank you!
Attached screenshots

All Replies (6)

more options

Just to clarify what Firefox means with that message: there was a glitch in the handshake where the browser and the site agree on how to make a secure connection. Sometimes doing a reload bypassing the cache -- Ctrl+Shift+R -- will work around it, but not always.

Although most people are not intentionally using a proxy server, Firefox may discover one set up in your system settings. Sometimes forcing Firefox to ignore those settings helps with weird connection issues. Here's how:

Open the Settings page using either:

  • "3-bar" menu button > Settings
  • (menu bar) Tools > Settings
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section of the page.

Click the Settings button, change the top setting to "No Proxy" and then click the OK button at the bottom of the dialog to save your change.

Any difference?

Helpful?

more options

jscher2000 - Support Volunteer said

Just to clarify what Firefox means with that message: there was a glitch in the handshake where the browser and the site agree on how to make a secure connection. Sometimes doing a reload bypassing the cache -- Ctrl+Shift+R -- will work around it, but not always. Although most people are not intentionally using a proxy server, Firefox may discover one set up in your system settings. Sometimes forcing Firefox to ignore those settings helps with weird connection issues. Here's how: Open the Settings page using either:
  • "3-bar" menu button > Settings
  • (menu bar) Tools > Settings
  • type or paste about:preferences into the address bar and press Enter/Return to load it
In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section of the page. Click the Settings button, change the top setting to "No Proxy" and then click the OK button at the bottom of the dialog to save your change. Any difference?

I've set the settings to no proxy, but it's still giving me the secure connection failed page :(

Helpful?

more options

hii peterturbo_apologist,

Firstly make sure your connection is stable and one more thing please check your laptop or desktop time is correct. if both are correct otherwise please correct them.

Now moves on and change some setting in your browser.

  • Disable the VPN client or proxy service
  • Disable security software (after fixed your issue again enable it)
  1. Adjust SSL setting on Firefox

1) Open Firefox. Type about:config in the address bar and press Enter key on your keyboard. 2) The warning page would shows up. Click I accept the risk to go on. Copy security.ssl.enable_ocsp_stapling from here to paste on the search bar of the open page. Then double-click on it from the result to set its Value to be false. Now try to connect the website again to see if the error has gone.

Thank Regards -Arman

Helpful?

more options

ARMAN KHAN said

hii peterturbo_apologist, Firstly make sure your connection is stable and one more thing please check your laptop or desktop time is correct. if both are correct otherwise please correct them. Now moves on and change some setting in your browser.
  • Disable the VPN client or proxy service
  • Disable security software (after fixed your issue again enable it)
  1. Adjust SSL setting on Firefox
1) Open Firefox. Type about:config in the address bar and press Enter key on your keyboard. 2) The warning page would shows up. Click I accept the risk to go on. Copy security.ssl.enable_ocsp_stapling from here to paste on the search bar of the open page. Then double-click on it from the result to set its Value to be false. Now try to connect the website again to see if the error has gone. Thank Regards -Arman

No VPN, set it to off. Doesn't work! :(

Helpful?

more options

Still a PR_END_OF_FILE_ERROR ? I don't know whether it will make a difference, but you could delete your Google cookies. On the Settings page, Privacy & Security panel, Cookies and Site Data section, click the "Manage Data" button to remove just your Google cookies.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.