Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google services work intermittently

  • No replies
  • 0 have this problem
  • 5 views
more options

Hello, recently google services are not working well any more (windows 10). Sometimes google works, and a minute later firefox doesn't load google pages, then it works again. Sometimes google pages seem to load well, but interactivity doesn't work. I can't figure out what's the cause and i even can't tell if it started with an update. I tried uninstalling and reinstalling. I tried deleting cache, cookies, temp and everything else. I tried removing the Mozilla folder in the appdata folder, then restoring back my data via sync with firefox account. Every time it seems to work, but after a day or so, the problem arises again. I use firefox since the beginning, and even before i can recall something like a mozilla suite, so you can believe me if i tell that i don't want to change browser. But at theese conditions, it's really hard to browse the web. Can someone help me with this annoying issue?

Hello, recently google services are not working well any more (windows 10). Sometimes google works, and a minute later firefox doesn't load google pages, then it works again. Sometimes google pages seem to load well, but interactivity doesn't work. I can't figure out what's the cause and i even can't tell if it started with an update. I tried uninstalling and reinstalling. I tried deleting cache, cookies, temp and everything else. I tried removing the Mozilla folder in the appdata folder, then restoring back my data via sync with firefox account. Every time it seems to work, but after a day or so, the problem arises again. I use firefox since the beginning, and even before i can recall something like a mozilla suite, so you can believe me if i tell that i don't want to change browser. But at theese conditions, it's really hard to browse the web. Can someone help me with this annoying issue?

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.