Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar does not resolve local DNS (on Desktop and Android)

  • 3 replies
  • 0 have this problem
  • 6 views
  • Last reply by Archirk

more options

I try to configure DNS server on Synology NAS. NAS has static ip address(192.168.0.30) on local network. I installed DNS server and added zone(nas with A record my.nas - 192.168.0.30). DNS server also added to router.

I am sure that DNS server configured properly because when I do in command line: curl my.nas and curl 192.168.0.30 provide same successful response and dig my.nas also show expected response.

Proxy options and DoH **are disabled** in my Firefox. Futhermore, on page `about:networking#dnslookuptool` browser resolves `my.nas` correctly.(scrrenshot)

However when i enter `my.nas` into address bar in Firefox(Desktop and mobile) it can not resolve it (in my case forward me to NAS login page)

I try to configure DNS server on Synology NAS. NAS has static ip address(192.168.0.30) on local network. I installed DNS server and added zone(nas with A record ''my.nas - 192.168.0.30''). DNS server also added to router. I am sure that DNS server configured properly because when I do in command line: ''curl my.nas'' and ''curl 192.168.0.30'' provide same successful response and ''dig my.nas'' also show expected response. Proxy options and DoH **are disabled** in my Firefox. Futhermore, on page `about:networking#dnslookuptool` browser resolves `my.nas` correctly.(scrrenshot) However when i enter `my.nas` into address bar in Firefox(Desktop and mobile) it can not resolve it (in my case forward me to NAS login page)
Attached screenshots

All Replies (3)

more options

Try updating your local host file (/etc/hosts) with something like this...

192.168.0.30 my.nas

Modified by jonzn4SUSE

Helpful?

more options

I like to block Facebook. My host file has 127.0.0.1 facebook and when I enter facebook in the address bar I get nothing.

Modified by jonzn4SUSE

Helpful?

more options

jonzn4SUSE said

Try updating your local host file (/etc/hosts) with something like this... 192.168.0.30 my.nas

That not desired solution even if it works.

Current workaround is to disable google-search from address bar. Because, apparently, if zone is not publicly available(like com, net, dev etc) Firefox does not try to resolve it and redirects query to search engine.

Modified by Archirk

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.