Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 105.0.3 (64-bit) - add-on drop-down menus are back w/white text. I need white w/black text

  • 1 reply
  • 0 have this problem
  • 27 views
  • Last reply by Terry

more options

I have selected a particular theme (Classic Marine Blue) which I like. However, when I click on an item that has a dropdown menu, the background color of the dropdown is black with white text. I prefer white with black text. For example, this happens with the Library item with the drop downs Bookmarks, History, and Downloads.

I've tried using Firefox Colors, and couldn't solve the problem with a custom theme.

I get it that this happens because the text color on most of the toolbars is white, which apparently triggers Firefox to flip to a black background rather than staying with the original white background.

I don't wish to change the theme. All I want is my black-text on white-background drop down colors back.

Any suggestions? Please help. This is really annoying.

I have selected a particular theme (Classic Marine Blue) which I like. However, when I click on an item that has a dropdown menu, the background color of the dropdown is black with white text. I prefer white with black text. For example, this happens with the Library item with the drop downs Bookmarks, History, and Downloads. I've tried using Firefox Colors, and couldn't solve the problem with a custom theme. I get it that this happens because the text color on most of the toolbars is white, which apparently triggers Firefox to flip to a black background rather than staying with the original white background. I don't wish to change the theme. All I want is my black-text on white-background drop down colors back. Any suggestions? Please help. This is really annoying.
Attached screenshots

All Replies (1)

more options

You can try changing layout.css.prefers-color-scheme.content-override in about:config to: dark (0), light (1), system (2) or browser (3).

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

If that doesn't work, you could try creating a file userChrome.css. I don't know whether code for menu colours would work against a theme.