Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed

  • 4 replies
  • 0 have this problem
  • 23 views
  • Last reply by Mark Foley

more options

I have a SonicWall firewall on our office network. I can log into it from an office workstation, but when I try to export/save its Configuration I get the "Secure Connection Failed" message. I've searched for a solution to this but have only turned up two:

1) Disabling SSL Scanning Feature in Your Antivirus Software.

2) By Changing the SSL Settings On Firefox

Neither of these are desirable. For option 1, this computer is using Windows Defender, and disabling SSL scanning is not a feature that I know of. In either case, these solutions are across-the-board and would affect all pages I go to whereas the only one I'd like to get to is this SonicWall device located on our internal LAN.

I recall that Firefox used to allow you to make an exception on a per-site basis. Is this no longer possible? Is there any other way to accomplish this without disabling SSL validation for all sites?

I have a SonicWall firewall on our office network. I can log into it from an office workstation, but when I try to export/save its Configuration I get the "Secure Connection Failed" message. I've searched for a solution to this but have only turned up two: 1) Disabling SSL Scanning Feature in Your Antivirus Software. 2) By Changing the SSL Settings On Firefox Neither of these are desirable. For option 1, this computer is using Windows Defender, and disabling SSL scanning is not a feature that I know of. In either case, these solutions are across-the-board and would affect all pages I go to whereas the only one I'd like to get to is this SonicWall device located on our internal LAN. I recall that Firefox used to allow you to make an exception on a per-site basis. Is this no longer possible? Is there any other way to accomplish this without disabling SSL validation for all sites?

Chosen solution

Well, I solved the problem by using Edge. Edge came up with the same secure connection warning, but the page also had an 'Advanced' button that let me make an exception for this URL.

Firefox used to have such an option. What happened to it? Is it something that can be set in the config?

Read this answer in context 👍 0

All Replies (4)

more options

Internal logins isn't the same as going from outside or remote. You should talk or contact your IT on how to remote in. As this is a possible security risk - I don't think you can just copy configuration and expect outside login as the system will flag it as outside connect and block it.

Helpful?

more options

Thanks for your reply. Not sure why you're thinking this is an "outside or remote" connection. I am connecting to the SonicWall from a workstation on the same LAN inside the office. Also - BTW, I *am* the IT for this company!

Helpful?

more options

Sorry, I'm not following you at all. I'm on a Windows workstation located in our office. I use Firefox to connect to the SonicWall firewall on our office network at 192.168.x.y. I log in successfully. On the SonicWall admin web page, I click on the option to "Import/Export Configuration". It comes up with a dialogue to click the 'Export' button (see image). When I do so I get the "Secure Connection Failed" message in the browser.

There is only the one computer, the one internal network. Nothing remote. No moving anything between computers.

Helpful?

more options

Chosen Solution

Well, I solved the problem by using Edge. Edge came up with the same secure connection warning, but the page also had an 'Advanced' button that let me make an exception for this URL.

Firefox used to have such an option. What happened to it? Is it something that can be set in the config?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.