Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error 400 - Bad Request The request could not be understood by server due to malformed syntax.

  • 2 replies
  • 0 have this problem
  • 15 views
  • Last reply by cor-el

more options

For the past 8-10 days, every time I try to log-on to: https://selfservice.telkom.co.za/rococo/public/content/interstitial I click "Login" under the Mobile & Home heading and I receive the following message returned.

Bad Request The request could not be understood by server due to malformed syntax.

I have used MS EDGE browser and do not get the same problem, it log's-on OK.

As such it seems that it is a Firefox problem.

For the past 8-10 days, every time I try to log-on to: https://selfservice.telkom.co.za/rococo/public/content/interstitial I click "Login" under the '''Mobile & Home''' heading and I receive the following message returned. '''Bad Request''' The request could not be understood by server due to malformed syntax. I have used MS EDGE browser and do not get the same problem, it log's-on OK. As such it seems that it is a Firefox problem.

Modified by Brian E

Chosen solution

This issue can be caused by corrupted cookies or blocked cookies.

  • check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions"

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

If clearing cookies doesn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Read this answer in context 👍 1

All Replies (2)

more options

Chrome is not working as well so not sure how your using Edge to access it.

Helpful?

more options

Chosen Solution

This issue can be caused by corrupted cookies or blocked cookies.

  • check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions"

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

If clearing cookies doesn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.