Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent Firefox from remembering/displaying login names for sites which are not set to remember credentials

more options

Prevent Firefox from remembering/displaying login names for sites which are set to not remember credentials

I regularly see suggested login names for sites such as my credit card companies. I highlight them, delete them, and days later, they are back again. I never want selected web site login pages to show suggested login names. How do I prevent Firefox from doing this.

I do wish to have user ID and passwords auto-filled for some sites. I am happy with some Forms data being remembered, such as name & address.

Suggestions ???

Prevent Firefox from remembering/displaying login names for sites which are set to not remember credentials I regularly see suggested login names for sites such as my credit card companies. I highlight them, delete them, and days later, they are back again. I never want selected web site login pages to show suggested login names. How do I prevent Firefox from doing this. I do wish to have user ID and passwords auto-filled for some sites. I am happy with some Forms data being remembered, such as name & address. Suggestions ???

All Replies (2)

more options

The AutoFill/AutoSave is either on/off you can't have it both way when using this feature.

Helpful?

more options

Firefox has multiple form filling features:

You can turn these on and off individually to see which one is responsible for the unwanted suggestions.

If the suggestions persist even after these are turned off, it's possible the site is suggesting data you previously entered. You can flush the site's cookies and local data as a temporary fix but it's possible the site will keep doing it. To test that:

While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. Firefox will ask you to confirm; go ahead and confirm.

Then try reloading the page. Suggestions gone?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.