Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email Text Link Will Not Open ONLY in Thunderbird

  • 4 replies
  • 0 have this problem
  • 4 views
  • Last reply by Fillip

more options

New to Thunderbird (TB). TB v 102.1.1 (64bit) Mac Mini late 2012 macOS 10.15.7 Catalina.

Situation: My coach sent me a link to download a PDF. She sent the email with both an image link and a text link. I use "Choosy" as my browser, a nifty Mac App that allows me to choose any of my four browsers.

The Problem: I have normally been using Kiwi for Gmail v3.5.0. IMPORTANT: Both links work. The image link AND the text link are clickable. I also checked using MailPlane, another Mac App, and again, Both links, the image link and the text link were clickable.

However, only in Thunderbird does the "text link not work". The image link does work, i.e. it will open in my browser.

What I've done: > Cleared the cache > Open in Troubleshoot mode > Referred to this help link (nothing helped): https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working > Tried Message Body "Simple HTML" ==> Only the 'image link' becomes an HTML clickable link. The text link remains as text. > Just for funzies: Copied the text link and pasted into Chrome, it opened the PDF. > Another for funzies: I copied the PDF link from my browser, pasted it into another account using TB, send the email with the "text link" to another account. batta-bing-batta-boom, the link showed up.

My Conclusion: I'm a bit mystified. There has to be some setting problem in TB. Because as I mentioned earlier, both the image link and text link open in my browser when using Kiwi for Gmail and MailPlane App. Only in TB the text link will not open.

Open to any suggestions. Please note: no biggie as the image link is clickable.

New to Thunderbird (TB). TB v 102.1.1 (64bit) Mac Mini late 2012 macOS 10.15.7 Catalina. Situation: My coach sent me a link to download a PDF. She sent the email with both an image link and a text link. I use "Choosy" as my browser, a nifty Mac App that allows me to choose any of my four browsers. The Problem: I have normally been using Kiwi for Gmail v3.5.0. IMPORTANT:''' Both links work.''' The image link AND '''the text link are clickable'''. I also checked using MailPlane, another Mac App, and again,''' Both links, the image link and the text link were clickable.''' However, '''only''' in Thunderbird does the "'''text link not work'''". The image link does work, i.e. it will open in my browser. What I've done: > Cleared the cache > Open in Troubleshoot mode > Referred to this help link (nothing helped): https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working > Tried Message Body "Simple HTML" ==> Only the 'image link' becomes an HTML clickable link. The text link remains as text. > Just for funzies: Copied the text link and pasted into Chrome, it opened the PDF. > Another for funzies: I copied the PDF link from my browser, pasted it into another account using TB, send the email with the "text link" to another account. batta-bing-batta-boom, the link showed up. My Conclusion: I'm a bit mystified. There has to be some setting problem in TB. Because as I mentioned earlier, both the image link and text link open in my browser when using Kiwi for Gmail and MailPlane App. Only in TB the text link will not open. Open to any suggestions. Please note: no biggie as the image link is clickable.

All Replies (4)

more options

Thunderbird opens PDF files in one of it's own tabs. Have a look in preferences/Options and change how Thunderbird treats PDF files to set it to an external application

Helpful?

more options

Hi Matt, Thank you for reply. I want to confirm that there is no PDF file attached to the email, I have an image link and a text link to a PDF file. On the Mac version there's no "set to external application" TB > Settings > General > Files & Attachments > Content Type (PDF) > I have the following: Save File : Didn't work, text link remained unclickable. Preview in TB: Didn't work, that is the 'text link' remained unclickable I've pretty much accepted that TB PDF text files don't always work. Image links do. Again, thanks for your suggestions.

Helpful?

more options

Thunderbird does not guess what text is a link. It expects the sender to explicitly set that. If they do not bother to set it correctly, Thunderbird just treats it as plain text. I am guessing that is what is happening here.

Apple mail along with lots of mail applications guess about what is a link and what is not. This does present security problems as things that are plain text are interpreted as something else.

Helpful?

more options

Interesting. Still a bit baffling, for example the text links from no-reply@support.mozilla.org, (this community support thread) all work whereas the text link from my coaches email doesn't.

However, if I forward the message with the un-clickable text link to another account in Thunderbird the link becomes clickable.

A bit of a head scratcher, but no biggie. Thank you for explaining. Much appreciated.

Modified by Fillip

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.