Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Changing zoomlevel for all websites to 90% not possible with version 103.0.1 ?

more options

A few days ago I got the new Firefox version 103.0.1. And now áll websites I visit are larger than they were before, I didn't change anything and zoomlevel in e.g. about:preferences is still 100%

Now, with all the websites I visit I have to manually change the zoomlevel to 90%, to have them at the same level as before the update.

What do I have to change to have the zoomlevel set permanently at 90% ?

I've tried numerous times the "solution" Mozilla gives me: "Change zoomlevel in about:preferences to 90% but that doesn't work: no matter how many times I close Firefox, and restart, or restart the entire computer, it still defaults to 100%, and I still have to change the zoomlevel to 90% for each website I visit.

A few days ago I got the new Firefox version 103.0.1. And now áll websites I visit are larger than they were before, I didn't change anything and zoomlevel in e.g. about:preferences is still 100% Now, with all the websites I visit I have to manually change the zoomlevel to 90%, to have them at the same level as before the update. What do I have to change to have the zoomlevel set permanently at 90% ? I've tried numerous times the "solution" Mozilla gives me: "''Change zoomlevel in about:preferences to 90%'' but that doesn't work: no matter how many times I close Firefox, and restart, or restart the entire computer, it still defaults to 100%, and I still have to change the zoomlevel to 90% for each website I visit.

Chosen solution

Hi, do you mean the level on the Settings page changes back to 100%? That percentage is stored in the same file as the individual website zoom levels, and privacy settings and external cleanup software may prevent Firefox from saving those levels persistently.

But on the topic of changes in Firefox 103:

Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system. This one seems to be working for many people to revert the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi, do you mean the level on the Settings page changes back to 100%? That percentage is stored in the same file as the individual website zoom levels, and privacy settings and external cleanup software may prevent Firefox from saving those levels persistently.

But on the topic of changes in Firefox 103:

Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system. This one seems to be working for many people to revert the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

Helpful?

more options

It was the "Overall zoom level" that was causing it all. Went for Option (B), and it's all back to normal! Takes just 20 seconds or so.

Thank you véry much for your help! Would not have found the solution without you.

Helpful?

more options

Thank you for taking the time to report back!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.