Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Download History - remove "delete" option

  • 2 replies
  • 1 has this problem
  • 45 views
  • Last reply by lemming3k

more options

Hi,

Is there a way to remove the "delete" option when right clicking on items in the download history? It's unfortunately right above 'remove from history' and easy to mis-click. It has no confirmation and permanently deletes the file(s) without sending to the recycle bin which is quite annoying - especially as I'm not sure why you'd want to use this menu to delete something you just downloaded.

Thanks

Hi, Is there a way to remove the "delete" option when right clicking on items in the download history? It's unfortunately right above 'remove from history' and easy to mis-click. It has no confirmation and permanently deletes the file(s) without sending to the recycle bin which is quite annoying - especially as I'm not sure why you'd want to use this menu to delete something you just downloaded. Thanks

Chosen solution

You can possibly use code in the userChrome.css file in the chrome folder in the Firefox profile folder to hide this menu item.


.downloadDeleteFileMenuItem { display: none !important; }

More info about userContent.css and userChrome.css in case you are not familiar: *https://www.userchrome.org/what-is-userchrome-css.html

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

You can possibly use code in the userChrome.css file in the chrome folder in the Firefox profile folder to hide this menu item.


.downloadDeleteFileMenuItem { display: none !important; }

More info about userContent.css and userChrome.css in case you are not familiar: *https://www.userchrome.org/what-is-userchrome-css.html

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Helpful?

more options

Thank you! That seems to have done the trick.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.