Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is too big (have already tried scroll wheel zoom, layout.css.devPixelsPerPx, compact mode and many, many more)

  • 5 replies
  • 0 have this problem
  • 68 views
  • Last reply by Paul

more options

Every time Firefox updates itself, all of the text and images and page layouts become huge. I have tried every single fix that is usually suggested for this issue:

Zoom out with scroll wheel: Makes text smaller (and images, if I disable zoom text only) but does not fix page layouts (ex. Google search still has a horizontal scroll bar, even in full screen.)

layout.css.devPixelsPerPx: No effect at all. Can be made bigger at values over 1.0, but not smaller.

Compact mode: Sizes down the toolbar, but nothing in the webpages themselves.

Refresh Firefox: Still huge.

Safe Mode: Still huge.

Disabled all extensions: Still huge.

Complete uninstall with all leftover system files removed with RevoUninstaller, then reinstall: Still huge.

Other browsers: Display correctly. Absolutely no issues with size, including Firefox forks like Librewolf. (See attached image for direct comparison between the two browsers.)

I can temporarily alleviate the issue by using a restore point on my computer from about a week ago but when I opened Firefox this morning, it bumped me to an update page, and everything was huge again.

I was previously using a non-native screen resolution while I was recovering from surgery in bed and the screen was too far to see at 1920x1080. But I did not have this problem for two months of recovery. It started just a couple days ago. Returning the screen to its native resolution has not resolved the issue. Firefox, and only Firefox, is still enormous.

Every time Firefox updates itself, all of the text and images and page layouts become huge. I have tried every single fix that is usually suggested for this issue: Zoom out with scroll wheel: Makes text smaller (and images, if I disable zoom text only) but does not fix page layouts (ex. Google search still has a horizontal scroll bar, even in full screen.) layout.css.devPixelsPerPx: No effect at all. Can be made bigger at values over 1.0, but not smaller. Compact mode: Sizes down the toolbar, but nothing in the webpages themselves. Refresh Firefox: Still huge. Safe Mode: Still huge. Disabled all extensions: Still huge. Complete uninstall with all leftover system files removed with RevoUninstaller, then reinstall: Still huge. Other browsers: Display correctly. Absolutely no issues with size, including Firefox forks like Librewolf. (See attached image for direct comparison between the two browsers.) I can temporarily alleviate the issue by using a restore point on my computer from about a week ago but when I opened Firefox this morning, it bumped me to an update page, and everything was huge again. I was previously using a non-native screen resolution while I was recovering from surgery in bed and the screen was too far to see at 1920x1080. But I did not have this problem for two months of recovery. It started just a couple days ago. Returning the screen to its native resolution has not resolved the issue. Firefox, and ''only'' Firefox, is still enormous.
Attached screenshots

Chosen solution

Yes, Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system. This one seems to be working for many people to revert the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

Let us know whether that helps -- fully, partially, or not at all.

Read this answer in context 👍 1

All Replies (5)

more options

Edit: Have also tried restarting the computer in safe mode with networking and comparing the size of Firefox and Librewolf, Firefox is still much bigger.

Tried going into the shortcut compatibility mode, Change High DPI Settings, enabled "Use this settings to fix scaling problems for this program instead of the one in Settings" as per another support answer. Still huge.

Running directly from .exe file rather than shortcut also has no effect.

Setting my default zoom level to 67% and enabling compact mode almost gets it back to normal (as compared to other browsers at 100%) but there are still layout issues with some websites. And it still doesn't explain why the entire browser is suddenly zoomed in by about 40% after updating to latest version.

Modified by pooklet

Helpful?

more options

Chosen Solution

Yes, Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system. This one seems to be working for many people to revert the change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

Let us know whether that helps -- fully, partially, or not at all.

Helpful?

more options

Thank you jscher2000, that did the trick!

Helpful?

more options

Thank you for reporting back.

Helpful?

more options

Hi

While there is not an easy way to revert this our product team did suggest this about:config preference change as the optimal solution at this time.

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  3. In the search field, enter browser.display.os-zoom-behavior, select the pencil "edit" icon and change the number to 0.
  4. Select the check mark and restart Firefox.

They did note they would look into alternative options which may be present in a future update.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.