Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Zoom change in firefox 103, how to undo it?

  • 3 replies
  • 2 have this problem
  • 45 views
  • Last reply by Paul

more options

Firefox 103 screws with website zooming if you use the "Make text bigger" accessibility setting in Windows. 150% for example now zooms in a lot more with the accessibility setting in Windows set to 120%.

How do I undo this change so that 150% is 150% and not bigger than 150%? I had all my frequented websites set up how I liked it and now this comes along and messes it all up >:V at the moment it seems like 120% Firefox + 120% Accessibility is similar to what 150% in Firefox was like but it's not exactly the same. I've now gotta go futz with zoom levels for each web page I frequent again to find what looks most comfortable for each one.

Also this change greatly modifies consistency when it comes to the granularity of zooming. For example, what is 100% zoom when Accessibility is set to 120% so that I can avoid filtered scaling being applied to pictures? Why is the in-browser percentage indication not accurate with the level of zooming actually being applied?

The zoom level I choose is no longer the zoom level applied, there is now a multiplier in effect. So 50% isn't 50% anymore, 60% isn't 60% anymore, 70% isn't 70% anymore, 80% isn't 80% anymore, 90% isn't 90% anymore, 100% isn't 100% anymore, 110% isn't 110% anymore, 120% isn't 120% anymore, 130% isn't 130% anymore, 140% isn't 140% anymore etc.

A website that looked good at 133% can no longer be viewed at 133% if the Accessibility setting isn't also 133%.

Not a fan of whoever decided to implement this seemingly without a way to turn it off.

Firefox 103 screws with website zooming if you use the "Make text bigger" accessibility setting in Windows. 150% for example now zooms in a lot more with the accessibility setting in Windows set to 120%. How do I undo this change so that 150% is 150% and not bigger than 150%? I had all my frequented websites set up how I liked it and now this comes along and messes it all up >:V at the moment it seems like 120% Firefox + 120% Accessibility is similar to what 150% in Firefox was like but it's not exactly the same. I've now gotta go futz with zoom levels for each web page I frequent again to find what looks most comfortable for each one. Also this change greatly modifies consistency when it comes to the granularity of zooming. For example, what is 100% zoom when Accessibility is set to 120% so that I can avoid filtered scaling being applied to pictures? Why is the in-browser percentage indication not accurate with the level of zooming actually being applied? The zoom level I choose is no longer the zoom level applied, there is now a multiplier in effect. So 50% isn't 50% anymore, 60% isn't 60% anymore, 70% isn't 70% anymore, 80% isn't 80% anymore, 90% isn't 90% anymore, 100% isn't 100% anymore, 110% isn't 110% anymore, 120% isn't 120% anymore, 130% isn't 130% anymore, 140% isn't 140% anymore etc. A website that looked good at 133% can no longer be viewed at 133% if the Accessibility setting isn't also 133%. Not a fan of whoever decided to implement this seemingly without a way to turn it off.

Modified by Franpa

Chosen solution

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes.

To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes.

To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

Helpful?

more options

TyDraniu said

Windows' "Make text bigger" accessibility setting now affects all the UI and content pages, rather than only applying to system font sizes. To get stuff back to normal, reset Windows' "Make text bigger" setting to 100% or enter about:config in the URL bar and create a new number pref ui.textScaleFactor = 100.

Thank you, this variable also fixes webpage content zooming to be like it used to be.

Helpful?

more options

Hi

While there is not an easy way to revert this our product team did suggest this about:config preference change as the optimal solution at this time.

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  3. In the search field, enter browser.display.os-zoom-behavior, select the pencil "edit" icon and change the number to 0.
  4. Select the check mark and restart Firefox.

They did note they would look into alternative options which may be present in a future update.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.