Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Each time I send a message using Thunderbird is asks for a password and always fails

  • 37 replies
  • 2 have this problem
  • 406 views
  • Last reply by Toad-Hall

more options

I recently installed Thunderbird on a new computer.I set it up to use my Yahoo account. It does receive emails sent to Yahoo but will not send. Every time i click SEND it asks for a password and always says it failed.

Under settings, there are 2 servers, IMAP and SMTP. Each has a different password, but at one point I made them the same. It does not matter because the outgoing server keeps changing its password to about 20 random letter and characters. At one point I copied these random characters into the clipboard and posted it in after it asked for a password...and it still FAILS.

I am using version 81.0.19 Until I get this fixed it is useless. An annoying thing is that each time I start Thunderbird, it asks for the password...on my previous pc it remembered it. Both machines are Windows 10. Can anyone help?

I recently installed Thunderbird on a new computer.I set it up to use my Yahoo account. It does receive emails sent to Yahoo but will not send. Every time i click SEND it asks for a password and always says it failed. Under settings, there are 2 servers, IMAP and SMTP. Each has a different password, but at one point I made them the same. It does not matter because the outgoing server keeps changing its password to about 20 random letter and characters. At one point I copied these random characters into the clipboard and posted it in after it asked for a password...and it still FAILS. I am using version 81.0.19 Until I get this fixed it is useless. An annoying thing is that each time I start Thunderbird, it asks for the password...on my previous pc it remembered it. Both machines are Windows 10. Can anyone help?

Chosen solution

ADDITIONAL Whilst Thunderbird is closed - after you have deleted the files mentioned previously.

access : C:/Users/ User Account/Appdata/Local/Thunderbird/Profiles/ Please note this is the Appdata 'Local' location which the computer uses as a cache. Be sure you are in the 'Local' and not the 'Roaming' Delete the contents of the 'Profiles' folder.

then start Thunderbird.

Read this answer in context 👍 1

All Replies (20)

more options

12 hours later, I uninstalled Thunderbird ,downloaded it, and installed it. I sent a message to a gmail address and it said "sending" for 4 or 5 minutes before I clicked cancel.

I tried it again and it is asking for a password again.

more options

For the SMTP server, it created a 40 character password. I copied and pasted it in when it asked for a password from the SMTP Server, and it is frozen at "sending massage" for 5 minutes now. It is as though Thunderbird was never intended to connect to a Yahoo account.

more options

What created this random password? Until we get that resolved I doubt any progress will occur.

Yahoo (including SMTP server) are supposed to use an oauth 2.0 authentication method and that process loads web pages where authentication occurs and the resulting "token" which is stored is as you say a random collection of letters and numbers and is unique to the protocol, post and application. So the one for IMAP or POP can not be used for SMTP. You have to step through the authentication process complete for each protocol.

more options

Matt, I uninstalled Thunderbird again, then reinstalled it today. When I look at saved logins, there is one for the Yahoo IMAP server, and one for oauth://login.yahoo.com (mail-w), and this is the one with the long string of characters. I never entered anything...the re-installation picked up the previous values even though it was uninstalled. I can read mail, but not send any.I am not sure what the authentication process is. My guess is for pop, since it does not show up in saved logins. Can you point me to a webpage that shows how to authenticate pop3? Thank you.

more options

I now think this has nothing to do with pop. When I send an email I get the message "login to server smtp.mail.yahoo ...failed. I then click the middle button enter new password. I make up a new password and get an error message "not sent. connection to outgoing server smtp.mail.yahoo was lost in the middle of the transaction. try again". It fails each time with the same error. I get the same message if I entry my existing password.

more options

open your account settings. go to the outgoing server (SMTP) entry. Select your SMTP server for Yahoo in the list and change the authentication method to oauth.

more options

Still not working. I thought it was already set to OAuth2, but it turns out there are 2 different places to set it: 1) under preferences, show passwords, and 2) under Outgoing Server SMTP, where I just set it.In both places, the auth method is "OAuth2". There was no OAuth in the dropdown without the ending 2.

After I clicked on Send, a screen came up saying something like "sign in with Google". I was trying to send it to a Hotmail address, and have no clue why it said to sign in with Google, but I clicked the button, it took me to GMAIL on the web, and I signed in. The result was another failure where it said it could not connect to the Yahoo SMTP server. I tried again and it asked for a password, so I entered my Yahoo password. The error message said the connection failed.

I then went to gmail on the web and sent a message to my yahoo account. Went back into Thunderbird and the message from gmail was there (as usual, it has always been able to receive. I clicked reply and this time there was no error message or password request, but it never sent it...it was frozen on the "sending message". After maybe 4 minutes I hit cancel...it was in a loop....it kept giving me the sending message after I hit cancel or the esc key 40 times. I had to go into task manager to do an "end task".

Any ideas?

more options

re : I make up a new password

You cannot just make up a new password in Thunderbird. You can only modify/change a password via the webmail account for the email address accessed via a browser.

re :After I clicked on Send, a screen came up saying something like "sign in with Google".

If you wanting to send from a yahoo email address via a yahoo smtp server then that sounds like you have got all your outgoing servers wrong.

So you need to check all of them and then make sure each mail account is actually using the correct smtp server.

Menu app icon > Account Settings Left Pane - Scroll to the bottom and below 'Local Folders' you will see 'Outgoing Server (SMTP)' - click on it. On the right it will display the list of outgoing servers.

I do not know how many mail accounts you have or whether you have more than one that use same settings. You should have one smtp for each email address/mail account. Where the user name = email address of account.

  • Select the first smtp in list and click on 'Edit'
  • Description: this field is for personal use. So use it for the email address which is the same as you see in the 'User Name' section. This will be useful as will become very clear later on.
  • Make sure the correct server settings are used.
  • Click on ok

Select the next smtp in list and repeat same process. You should have one smtp for each mail account.

When all are checked and ok, you now need to make sure each mail account is actually using the correct smtp serve. In left Pane - select name of account and look bottom right for the 'Outgoing Server (SMTP)'. The info you see in the text box should now show the email address and it should be exactly the same as the mail account you selected. If is not the same then do this: Click on the drop down option and select the one with correct eamil address. DO NOT click on the button 'Edit Server_SMTP' as you could end up editing a smtp that is used for a different account.

In Left Pane - Select second mail account and same as previously, check to see what Outgoing Server it is set up to use. Use the drop down option to select correct email address which is same as account name.

Repeat for all your mail accounts.

Now restart Thunderbird to ensure all correct smtp for accounts is being used.

Post the following: Menu app icon > Help > More Troubleshooting Information Under 'Mail and News Accounts' Select all info and post it into this question in forum, so we can see what you are using for server settings.

more options

Thank you. I have uploaded a screen print of the smtp server.

When I try to send it, it brings up a gmail log in screen, even though I an not emailing it to a gmail address. The only connection I see is that the yahoo address is set up in gmail as my alternate address in case I get locked out of gmail.

I did not continue because it has failed several times.

more options

Yes, I just wasted a full two hours running in circles trying to follow the recommendations of the "experts" I know NOTHING of emails (and plan to stay ignorant)

The answer is in a reddit post: https://www.reddit.com/r/Thunderbird/comments/v7ziud/how_i_fixed_oauth_problems_in_a_tb_profile_with_2/ "The gmail popups won't let me enter passwords... it just refreshes over and over with the email account box. Yes the accounts are still valid and working."

Go to Thunderbird -> Preferences -> Privacy and Security In the Web Content section:

ACCEPT ALL COOKIES - it is as yet unclear whether should be only all third party ect. and how long to keep them

This IMMEDIATELY worked and all of my mail since June 6th downloaded

more options

Did not work for me...I already had checked "Accept cookies from sites" and there are no exceptions. And for "Accept third party cookies" it is set at "Always" and "Keep until they expire".

I went into "saved Passwords" and did a "Remove all" hoping that starting over will help.

more options

I restarted Thunderbird and it asked forthe password for the yahoo account. I went to another email, protonmail, and sent myself a test message to my yahoo address. This message DOES show up in the inbox using Thunderbird. I clicked reply, entered a few words, clicked send, and go this error: Login to server smtp.mail.yahoo.com with user name sjl_computing failed.

When I go to Thunderbird settings, the outgoing server smtp.mail.yahoo.com looks correct: port 587, connection security = Starttls, Authentication method is Oauth2, user name is sjl_computing. When I go back to saved logins, where I previously deleted all, there are now 2 entries oauth://login.yahoo.com with username sjl_computing@yahoo.com, and oauth://accounts.google.com username = sjl_computing. When I show passwords, both are a long list of random characters, not the password I use to log into yahoo.mail.

So back to where Ihave been for several days...I can receive emails but cannot send.

more options

bschre022 said

Yes, I just wasted a full two hours running in circles trying to follow the recommendations of the "experts" I know NOTHING of emails (and plan to stay ignorant) The answer is in a reddit post: https://www.reddit.com/r/Thunderbird/comments/v7ziud/how_i_fixed_oauth_problems_in_a_tb_profile_with_2/ "The gmail popups won't let me enter passwords... it just refreshes over and over with the email account box. Yes the accounts are still valid and working." Go to Thunderbird -> Preferences -> Privacy and Security In the Web Content section: ACCEPT ALL COOKIES - it is as yet unclear whether should be only all third party ect. and how long to keep them This IMMEDIATELY worked and all of my mail since June 6th downloaded

You have been posting this information in various questions. Please note the information you mention at link is identical to the information already given. If you are using a different OS then please remember to mention this as it may help others. However in this case, the user is using Windows 10, so if you are not using Windows 10 then your information will not help.

more options

mysystrashed said

I restarted Thunderbird and it asked forthe password for the yahoo account. Login to server smtp.mail.yahoo.com with user name sjl_computing failed. When I go to Thunderbird settings, the outgoing server smtp.mail.yahoo.com looks correct: port 587, connection security = Starttls, Authentication method is Oauth2, user name is sjl_computing.

The server settings are not correct. The 'user name' must be the full yahoo email address. Currently you have just the bit before the @. Please edit that Outgoing Server SMTP 'user name' to say the full yahoo email address.

In the Preferences 'Saved Passwords' section. re :oauth://accounts.google.com username = sjl_computing. Do you have a gmail account in Thunderbird? Because you do not have a gmail smtp server in the list. If you do have a gmail account, then it is not using a gmail smtp server because it does not exist. The username for that would be wrong as well.

re :I went to another email, protonmail, Is this an account in Thunderbird ?

Please Post the following information:

  • Menu app icon > Help > More Troubleshooting Information
  • Under 'Mail and News Accounts'
  • Select all info and post it into this question in forum, so we can see what you are using for server settings.
more options

Assuming you have edited the Yahoo smtp username = full yahoo email address.... In the Preferences > Privacy & Security click on 'Saved Passwords'

re :oauth://accounts.google.com username = sjl_computing.

If you do not have a gmail account (There is nothing listed as gmail in left pane in the Account Settings) then select that oauth line for gmail and click on remove. Then restart Thunderbird.

more options

I am using Windows 10. I have a gmail account, but never wanted it to be connected to Thunderbird.Same with protonmail. They exist mainly for me to have an email address to send test messages to Yahoo (which do hw up in the Thunderbird yahoo inbox).

I went into account settings, selected the outgoing server (yahoo) then went to preferences then show passwords. I deleted the gmail entry there. I tried to reply to an email I received from my gmail account 2 days ago, and when I click send it brings me to a GMAIL login screen. Let's say you have a gmail account and send me an email and I try to reply. I would never expect a gmail login screen for your account. I want en email sent to my gmail account to behave the same way...like it is some one else's email.

The same thing happens when I go into my protonmail account, send a message to my yahoo account, try to reply from within Thunderbird, and I get the Google "one account" log in screen.

Why does Google keep butting in...how do I get rid of it? It is as though GMAIL is somehow built into Thunderbird itself.

more options

I rebooted, and sent an email to yahoo from protonmail, using the proton web interface. I opened Thunderbird and the proton email is in the inbox. When I click send it brings me to the gmail popup. It entered my gmail address, then it asks me for gmail password. No way will I enter it. And the email was not to gmail, it was to proton.

It is hard for me to believe that Thunderbird is this bad...so I now conclude my machine is screwed up and a Windows reinstall will be needed. Before doing that, I will look for another mail client, and try it out. Can anyone recommend a mail client almost as good as Thunderbird?

more options

re :I tried to reply to an email I received from my gmail account

so this would have had FROM gmail email address TO yahoo email address and is seen in the Yahoo Inbox.

When you click on 'REply' what occurs? It opens new Write window. Is the 'FROM' your yahoo email address Is the 'TO' your gmail address

more options

Check something for me and report back on findings. In Account Settings select the name of the yahoo account

Confirm the following:

  • Account Name = yahoo email address
  • Email address = yahoo email address
  • Reply-to Address: No entry - empty.
  • DO NOT select checkbox 'Reply from this identity when delivery headers match'

Was this selected or not - uncheck it if selected.

more options

Please supply this info. Menu app icon > Preferences > General Scroll to bottom Click on 'Config Editor' button Accept warning :) In top search type : oauth Post an image of results.

  1. 1
  2. 2