Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Duckduckgo opens links as https://html.duckduckgo.com/html

  • 7 replies
  • 1 has this problem
  • 27 views
  • Last reply by jlcenter

more options

Hi,

I'm using Duckduckgo as my search engine, but when I type in a search string, it Firefox prepends it with https://html.duckduckgo.com/html/... This opens a search page that doesn't follow my dark theme. When I click on a link, another link is added that creates a link back to the same URL, causing a loop. This never happened before I upgraded to Ubuntu 22.04 & the latest version of Firefox, 100.0.2. How can I change this back?

Thanks!

   -John
Hi, I'm using Duckduckgo as my search engine, but when I type in a search string, it Firefox prepends it with https://html.duckduckgo.com/html/... This opens a search page that doesn't follow my dark theme. When I click on a link, another link is added that creates a link back to the same URL, causing a loop. This never happened before I upgraded to Ubuntu 22.04 & the latest version of Firefox, 100.0.2. How can I change this back? Thanks! -John

Chosen solution

jscher2000,

I think you may have hit the issue. I'm using the DuckDuckGo search plugin. (Though I also have the DuckDuckGo Privacy Essentials installed, too.) I do have javascript blocked generally, but I thought I had enabled it for DuckDuckGo. It turns out that the way it rewrites the search URL is different than how I allowed uBlock Origin to pass it through.

The newtab.about-scheme had javascript disabled, which DuckDuckGo inherited. So the initial search was sent with javascript disabled so DuckDuckGo rewrote the URL to not use javascript! Once I enabled javascript for newtab.about-scheme, DuckDuckGo stopped rewriting the search URL & everything is now working.

Thanks for pointing me in the right direction to resolve the issue!

   -John
Read this answer in context 👍 0

All Replies (7)

more options

Show us a screenshot of the search and how what your typing so others can replicate the same typing and on the same page to see what they get.

Helpful?

more options

I have tested this and DDG gives me the usual search page without prepending anything. I am using the search bar rather than the address bar so that may make a difference. I am also using a search engine from the Mycroft project rather than an add-on.

Helpful?

more options

I can't capture the issue in a screenshot, but you can see the problem when you right click on the back arrow. 1) The first link is the original new tab.

2) The next URL is the initial search, in this case I was searching "wayland window manager":

   https://duckduckgo.com/?t=ffab&q=wayland+window+manager&atb=v323-2

3) This URL is then rewritten as:

   https://html.duckduckgo.com/html?q=wayland%20window%20manager

4) If I go to one of the search results, I get an additional URL inserted into the list:

   'https://duckduckgo.com/l/?uddg=https%3A%2F%2Funix.stackexchange.com%2Fquestions%2F254946%2Fwindow%2Dmanager%2Dwith%2Dwayland&rut=116bde84dc5b699643c5ee494cfd62b57594a8dcc5be408fbcf95730dc0a6627'

5) Then the URL I wanted to go to:

   https://unix.stackexchange.com/questions/254946/window-manager-with-wayland

6) So once I'm on the webpage that I wanted to see, if I now click on the back arrow to go back to the original search results, I get redirected by (4) back to (5). The only way to go back to the search results is to drop down the history, skip (4) to get back to the results page. It's very frustrating.

Thanks for your help!

   -John

Helpful?

more options

I wonder where the "atb=v323-2" is coming from. That doesn't seem to cause any problems for me, but it's not part of the normal URL.

Are you using the built-in DuckDuckGo search plugin, or a DDG add-on, or a customized search add-on?

Helpful?

more options

By the way, https://html.duckduckgo.com/html looks like a simplified version of DDG. I get redirected there if I block JavaScript from running.

Helpful?

more options

You can look at the website appearance setting.

  • Settings -> General -> Language and Appearance -> Website Appearance

Helpful?

more options

Chosen Solution

jscher2000,

I think you may have hit the issue. I'm using the DuckDuckGo search plugin. (Though I also have the DuckDuckGo Privacy Essentials installed, too.) I do have javascript blocked generally, but I thought I had enabled it for DuckDuckGo. It turns out that the way it rewrites the search URL is different than how I allowed uBlock Origin to pass it through.

The newtab.about-scheme had javascript disabled, which DuckDuckGo inherited. So the initial search was sent with javascript disabled so DuckDuckGo rewrote the URL to not use javascript! Once I enabled javascript for newtab.about-scheme, DuckDuckGo stopped rewriting the search URL & everything is now working.

Thanks for pointing me in the right direction to resolve the issue!

   -John

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.