Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Deleting History

more options

I click dismiss and delete from history over and over and they keep coming back. Firefox is @#$%$%

I click dismiss and delete from history over and over and they keep coming back. Firefox is @#$%$%

Chosen solution

rod18 said

I do not speak computerese

Is the problem solved or are you still looking for more comments?

Read this answer in context 👍 0

All Replies (7)

more options

Did you tell the browser to not save your history?

Type about:preferences#privacy<enter> in the address box. The button next to History, select Use Custom Settings.

Helpful?

more options

I think you are referring to Shortcuts in the Firefox Home / new tab page: Customize items on your Firefox New Tab page.

Are the ones you can't dismiss the promotional ones near the beginning of the list, or items from your own history? There's a checkbox to remove promotional shortcuts. See: Customize your New Tab page to hide or display content.

Choosing Dismiss adds the URL to a block list, but if another link from the site has a variation in the URL, it needs to be blocked individually. Unfortunately, as far as I know, there isn't a feature to block all URLs from a site in one step.

Note: the block list is stored in your profile folder in the prefs.js file along with many other custom settings. Are you losing any other browser settings? If so, check out this article: How to fix preferences that won't save.

Helpful?

more options

Changes made manually on the Firefox Home page are stored in prefs that you can find on the about:config page.

  • browser.newtabpage.pinned => websites pinned to a tile
  • browser.newtabpage.blocked => websites (hash) removed by clicking the Dismiss in a tile

Helpful?

more options

I do not speak computerese

Helpful?

more options

Chosen Solution

rod18 said

I do not speak computerese

Is the problem solved or are you still looking for more comments?

Helpful?

more options

Fixed by someone who speaks English. Thank you

Helpful?

more options

Can you provide the solution for others who come across this thread?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.