Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

notifications on my destop

  • 3 replies
  • 1 has this problem
  • 19 views
  • Last reply by Bithiah

more options

Hi Support help!

In the last few days or so it seems these notifications are showing up after I log off and the computer goes to sleep. When I wake up the notifications are showing in the right side of my Mac.

Now today they are even more aggressive and stacking up.

I've managed my Apple security settings and activated the natural firewall that comes with my Mac.

My Mac is up to date with latest operational systems.

My Firefox browser form Mozilla is up to date.

I've never experienced this problem previous and I've been using Mac since 2005. I upgrade every few years. and my latest Mac computer is about a year 1/2 old.

I have no other issues with my computer or my browser, Firefox.

I've been troubleshooting this through Mozilla support and have no add-ons or newly installed plugins.

I have no plug ins installed.

I've looked at my Firefox security settings and I did not have the pop-up blocker on but I'm not experiencing any issues with pop ups per se and I use Adobe creative cloud and have many other sites I use that have pop up window to enter data and perform functions so I'm not going to set it to cause me problems getting my work done since that is not even the issue here.


This concern is a notification that keeps showing up and I started by clearing my cache space On Mozilla Firefox privacy settings.

Now I'm asking to see if there is something else I can do to stop this notifications form happening. Its likely a simple answer I simply over looked?

When I go into my notifications on Apple Mac notifications are allowed and in many cases I need them but in this case as this recent events of odd spammy notifications on Firefox I don't need them unless they are real and I need to do something.

I did not click on any of them or try to open them.

These notifications describe needing to stop viruses, my computer is at risk, urgent with red caution symbols and other urgent notifications. My Mozilla Firefox account does not show anything like that and all my security updates are done for Firefox.

Help, please? Is it something obvious or am I needing to take certain actions?

I've cleared the Firefox cache in accessing info on the settings. And when I send this I will close and restart my computer.

Maybe nothing but a few days ago doing research I clicked a article that seemed fine in my search results but it took me to a completely different page and it asked to allow or not allow notifications. I clicked away form the page by closing out the tab.

They could be related but I haven't figure out how to stop it. Thanks in advance.

Arigato, Namaste.

Hi Support help! In the last few days or so it seems these notifications are showing up after I log off and the computer goes to sleep. When I wake up the notifications are showing in the right side of my Mac. Now today they are even more aggressive and stacking up. I've managed my Apple security settings and activated the natural firewall that comes with my Mac. My Mac is up to date with latest operational systems. My Firefox browser form Mozilla is up to date. I've never experienced this problem previous and I've been using Mac since 2005. I upgrade every few years. and my latest Mac computer is about a year 1/2 old. I have no other issues with my computer or my browser, Firefox. I've been troubleshooting this through Mozilla support and have no add-ons or newly installed plugins. I have no plug ins installed. I've looked at my Firefox security settings and I did not have the pop-up blocker on but I'm not experiencing any issues with pop ups per se and I use Adobe creative cloud and have many other sites I use that have pop up window to enter data and perform functions so I'm not going to set it to cause me problems getting my work done since that is not even the issue here. This concern is a notification that keeps showing up and I started by clearing my cache space On Mozilla Firefox privacy settings. Now I'm asking to see if there is something else I can do to stop this notifications form happening. Its likely a simple answer I simply over looked? When I go into my notifications on Apple Mac notifications are allowed and in many cases I need them but in this case as this recent events of odd spammy notifications on Firefox I don't need them unless they are real and I need to do something. I did not click on any of them or try to open them. These notifications describe needing to stop viruses, my computer is at risk, urgent with red caution symbols and other urgent notifications. My Mozilla Firefox account does not show anything like that and all my security updates are done for Firefox. Help, please? Is it something obvious or am I needing to take certain actions? I've cleared the Firefox cache in accessing info on the settings. And when I send this I will close and restart my computer. Maybe nothing but a few days ago doing research I clicked a article that seemed fine in my search results but it took me to a completely different page and it asked to allow or not allow notifications. I clicked away form the page by closing out the tab. They could be related but I haven't figure out how to stop it. Thanks in advance. Arigato, Namaste.

Chosen solution

Hey there!

It seems you have done quite a bit of troubleshooting already! Have you tried deleting the current Firefox and reinstalling it?

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Hey there!

It seems you have done quite a bit of troubleshooting already! Have you tried deleting the current Firefox and reinstalling it?

more options

So awesome for you to suggest help. Thank you! Yes, I cleared the cache on Firefox, reset my preferences on Apple Notifications and turned on Apple's firewall. Then I restarted my computer and so far these spammy notifications have disappeared completely. Clearing cache means I need to log back in to all my sites. So I'm taking the extra step to reset passwords as I go. Analogy: most security issues chase the bull out of the barn. But if a person takes time to lock the door the bull might now get out? Also I didn't wait. As soon as it was a concern, I looked to solve it. Hava great day.

more options

Hahaha! Glad it is solved now!