Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incorrect site view

  • 7 replies
  • 1 has this problem
  • 40 views
  • Last reply by pete50

more options

Firefox refuses to show my website correctly on my MacBook Pro M1 Pro, using OS 12.2. All other browsers on show it correctly. Firefox on my iPhone and iPad show it correctly too. I have tried all the obvious things... refresh, clear cache, deleted the application and reinstalled. However, I still get the same disjointed view of my website.

Please see the first image of how it looks and the second image of how it should look doesn't seem to want to upload here!

The site is bodymind-fit.com

Firefox refuses to show my website correctly on my MacBook Pro M1 Pro, using OS 12.2. All other browsers on show it correctly. Firefox on my iPhone and iPad show it correctly too. I have tried all the obvious things... refresh, clear cache, deleted the application and reinstalled. However, I still get the same disjointed view of my website. Please see the first image of how it looks and the second image of how it should look doesn't seem to want to upload here! The site is bodymind-fit.com
Attached screenshots

Chosen solution

I just noticed a the word 'autoptimise' was mentioned in each in each line of error code. I checked my plugins and found the culprit was the Autoptimise plugin – eventhough it was switched off. When I deleted it, the problem disappeared. Problem seems to have been solved :)

Read this answer in context 👍 0

All Replies (7)

more options

There seems to be something indicated on the toolbar with a "3" that might mean 3 files were blocked. Can you click that button to see what is going on there?

More generally, if you open the developer tools (Command+Shift+i or F12 function key), there are two places to check for loading issues.

(1) Network Monitor (the Network tab in the developer tools)

Reload the page to start tracking the success to requests. Any problems loading the CSS files?

(2) Web Console (the Console tab in the developer tools)

Does Firefox give any explanation for not loading or not applying CSS files?

Helpful?

more options

The site shows quite differently in my browser so the issue may be related to your browsers settings or extensions.

Helpful?

more options

I am aware it works fine on some other people's machines. However, it used to work on mine perfectly. Then, after doing some minor updates on the site, it stopped showing correctly. It has happened before, but cleared after a day or two. However, this has been over 2 weeks now and I have re-installed Firefox and cleared the cache but it is still not displaying correctly.

Can you offer a solution, apart from going over to Chrome or Safari?

I prefer Firefox, need it to work on my own website.

Helpful?

more options

jscher2000, I think you are onto something. I disabled the 3 adblocker warnings, but that made no difference. However the Console tab has 4 warnings:

The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_0f334351803462a651f309eb6c507efa.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com Google Analytics and Tag Manager is being shimmed by Firefox. See https://bugzilla.mozilla.org/show_bug.cgi?id=1713687 for details. 2 sandbox eval code:1:9 The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/js/autoptimize_db0334465bc5da5516b733a866858db5.js/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com Loading failed for the <script> with source “https://www.bodymind-fit.com/wp-content/cache/autoptimize/js/autoptimize_db0334465bc5da5516b733a866858db5.js”. www.bodymind-fit.com:46:1 The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_541e2ced151704f4ff1844c6de47ec02.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_a7b97af477884ecdc67c60114e1ed0c0.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com

Any thoughts on what I need to do?

Helpful?

more options

If you open one of those image URLs, an HTML page likely will appear with some kind of error message.

Maybe you changed it already, but I'm not seeing "cache" in the URLs used in the page so I'm not sure why your Firefox is trying to retrieve those.

Helpful?

more options

The issue is only on my Homepage as all other pages are viewing OK.

The 4 warnings I had yesterday on the Homepage are now 5 today. I viewed the various Errors, Warnings, Logs etc tabs, it went up to 8 but, when I finished this message it is now have 11 warnings!!

This is crazy! PLEASE can anyone help?

ERRORS are showing: The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/js/autoptimize_db0334465bc5da5516b733a866858db5.js/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_0f334351803462a651f309eb6c507efa.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_a7b97af477884ecdc67c60114e1ed0c0.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/js/autoptimize_db0334465bc5da5516b733a866858db5.js/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_541e2ced151704f4ff1844c6de47ec02.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_0f334351803462a651f309eb6c507efa.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_541e2ced151704f4ff1844c6de47ec02.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com The resource from “https://www.bodymind-fit.com/wp-content/cache/autoptimize/css/autoptimize_a7b97af477884ecdc67c60114e1ed0c0.css/?v=79cba1185463” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff). www.bodymind-fit.com

​WARNINGS are showing: Google Analytics and Tag Manager is being shimmed by Firefox. See https://bugzilla.mozilla.org/show_bug.cgi?id=1713687 for details. 2 sandbox eval code:1:9 Loading failed for the <script> with source “https://www.bodymind-fit.com/wp-content/cache/autoptimize/js/autoptimize_db0334465bc5da5516b733a866858db5.js”. www.bodymind-fit.com:46:1

Helpful?

more options

Chosen Solution

I just noticed a the word 'autoptimise' was mentioned in each in each line of error code. I checked my plugins and found the culprit was the Autoptimise plugin – eventhough it was switched off. When I deleted it, the problem disappeared. Problem seems to have been solved :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.