Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some issues I encounter everytime

  • 1 reply
  • 1 has this problem
  • 4 views
  • Last reply by Kens

more options

The settings i saved just keep resetting at least once every two weeks, it's so hassle to change it back again to my preferred settings. e.g. Using Google as my default search engine, but after some time, it will reset as "Browser default" and the engine will change to Yahoo; It also happen when using a custom url. Just keep resetting!

Another issue I encounter: When I change the resolution of a video I'm watching on Youtube (from 720p to 1080p or above), it suddenly gets laggy; you can hear the audio from it but the visual itself gets laggy.

Hope you can fix it, Thank You!

The settings i saved just keep resetting at least once every two weeks, it's so hassle to change it back again to my preferred settings. e.g. Using Google as my default search engine, but after some time, it will reset as "Browser default" and the engine will change to Yahoo; It also happen when using a custom url. Just keep resetting! Another issue I encounter: When I change the resolution of a video I'm watching on Youtube (from 720p to 1080p or above), it suddenly gets laggy; you can hear the audio from it but the visual itself gets laggy. Hope you can fix it, Thank You!

All Replies (1)

more options

Oh, i forgot to mention that I'm using a Macbook Air, I think it's late 2010. I don't know if other users of the same unit have the same problem as me though.