Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fire Fox has gone for a shyte

  • 10 replies
  • 1 has this problem
  • 75 views
  • Last reply by Ian B Dunn

more options

WOW what's with F/F Worked fine yesterday, last week, last month, haven't changed anything. Today I opened it up and tried a Google search (www.google.com and I live in Canada) I get this id Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to www.google.com because this website requires a secure connection. www.google.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. https://www.google.com/search?client=firefox-b-d&q=help

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:

-----BEGIN CERTIFICATE-----
MIIDcjCCAlqgAwIBAgIQEIbZHWt0hJtK/XuqqBnkmzANBgkqhkiG9w0BAQsFADAj
MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMjAxMDEyMTU0
MDE5WhcNMzExMDEyMDg0MDE5WjAZMRcwFQYDVQQDDA53d3cuZ29vZ2xlLmNvbTCC
ASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBANJtODVCQ7UHemGuwZ/SNFPZ
RstVWSM4KLtjbZHiRqSEchz6nH+IhX06SunvhU1ugnGbSpUanczL66STLqPo78X8
ULdgNuN1tCopCafmLjOgy3t6aZshA/sdItyKe12uowUhu+KqVn9FeC16sgk2uKJJ
CER6fHNDSe+Xhu6X2bNdCPUhV0ECfKfBPPuK6oLVdunICBaTXIx1+zAv3fknlX85
Ml+8u7CGm2fwCKCkMgYWMDPAcaVruInf+9J6u/TzzDsPqb+XTtcXyiS1SYJwtsde
UpMCGEvbQYzjLDdDARraqv35HIG4JHdD99Ib1/f1pq0inbGiu04AU9zYJ/JG8HUC
AwEAAaOBqzCBqDATBgNVHSUEDDAKBggrBgEFBQcDATAMBgNVHRMBAf8EAjAAMA4G
A1UdDwEB/wQEAwIFoDAzBgNVHREELDAqgg53d3cuZ29vZ2xlLmNvbYIMKi5nb29n
bGUuY29tggpnb29nbGUuY29tMB8GA1UdIwQYMBaAFO1CfY69MTD1W8AQSto+B6Rf
KWxPMB0GA1UdDgQWBBTU5XfgWojgi1toVWSA3LQYDOZB7jANBgkqhkiG9w0BAQsF
AAOCAQEAGxnbO0DVv45PjYlsBo6l7Z+K6BLE2n9JKUTL1Xk9H3RncUwjtAtoK2vb
N2BRKUU942sgdtu131/xwQmjff+l3X90XIbWJqVFXUcTetIhDOSgFIyUAfvudPYw
7u4mUPDn02mWNHvb/SZObVHNwE/fjKWuV/2XxPy+LnHdGxneXicdGcaA6MPNZzGf
RC2lcDoyMth5W91OEfov2FSdyoHrLz5vYxHyb9nK8FIRlNJ9P7jKQOPzmFg2rTMk
EO0BYpRqrraJTVfUBRLbUE9KaZFNoU6y8fy1JOT0vg/YOavQGuJAJFWd+6ktDVpe
Cdr3MYXlElKpTwxTx3EsGFadBJ40fA==
-----END CERTIFICATE-----

Then I try and load Amazon... Did Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to www.amazon.ca because this website requires a secure connection www.amazon.ca has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. https://www.amazon.ca/?tag=hydcaabkg-20&hvadid=231015454001&hvpos=1t1&hvnetw=g&hvrand=2219692390578281202&hvpone=&hvptwo=&hvqmt=e&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9001437&hvtargid=kwd-13273016&ref=pd_sl_7na9ri0ehg_e&hydadcr=20060_10090745&gclid=CjwKCAiAwZTuBRAYEiwAcr67OUKH_X-Ol94xgBW0zteIYObKQqwNwT8aRmjP4CtZkr8PCILCcfvrzhoC8aMQAvD_BwE

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: false

Certificate chain:

-----BEGIN CERTIFICATE-----
MIIDbjCCAlagAwIBAgIQQhMD0ChvzK5P+b9TnEWbLDANBgkqhkiG9w0BAQsFADAj
MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMjAxMDEyMTYw
NTM2WhcNMzExMDEyMDkwNTM2WjAYMRYwFAYDVQQDDA13d3cuYW1hem9uLmNhMIIB
IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAo+LytS3SkDxmXUxYZZedgrNX
8JrjFoWkv8Xzv91EPqzmIYxQTdU1L7AurKjbwbZDRHjzCNyY3n5UYxxoW9Vyaasp
ff1slTCkLT5e2YaQL3DulhzzwHsLkOlCyvLw0ytL0BnjM3mdOaEUjKButDH9KNrF
akQ7Edi6DNaf/nhTZIdm1bqIcuk3xPqKYa6RL6IJ31/Da6ECkbm1ax7X4TVIq9Wd
gHhMd44e2SgHdFg5svcynK+ZvemVERNzDz5yXpACZ6E6HAEyzA4rvXLim45ePLB5
gzZdBrkf13PTobN+YbdZMTqToCrBnC8UyOOor4mbyjqMcz95+/RfTLrosQsoUQID
AQABo4GoMIGlMBMGA1UdJQQMMAoGCCsGAQUFBwMBMAwGA1UdEwEB/wQCMAAwDgYD
VR0PAQH/BAQDAgWgMDAGA1UdEQQpMCeCDXd3dy5hbWF6b24uY2GCCyouYW1hem9u
LmNhgglhbWF6b24uY2EwHwYDVR0jBBgwFoAU7UJ9jr0xMPVbwBBK2j4HpF8pbE8w
HQYDVR0OBBYEFO+y+uFkj43aITbbWjpO8ESnKlynMA0GCSqGSIb3DQEBCwUAA4IB
AQAsMJ/mnqm+HKAppLS7coHngDhIjqaUZelreLnXZ29+RxNzsJp+Sat6cQR6oFP+
p9imcSz55x/Jt4viN5RjpQy0J8knyc+96Q9eI4itgIbm7Nkr81x5cLVL/6VFMgMl
VRyoF/6NQhRhu1pfHSBS8/HgRLQDEQyhnIflEAJP+9dDhejymAjMlzz8PmO4oxAP
8ieXKnzSN+dw0reKdfWzTTnilOjAOwYGxKKd9JcPXCS+j8KYjHkuAClCusx1H6Yg
6Xjf64rXklZmtdkRtJcnAi9YjlhCBxb13CUxDSgcO51EICekCfRKgwuyY9DFmCGy
y4pScL9ZjCh7E9xgMMSnHBZd
-----END CERTIFICATE-----

So then I try and connect to my email server https://webmail.shaw.ca/ Hit login shows this in the address bar https://webmail.shaw.ca/#1 and it just sits there. . . . . . nothing, totally useless Did a full antivirus scan with Defender and then Trend House call, nothing Went to my wife's laptop that is identical and everything works fine. Loads fine So I uninstalled Firefox reinstalled and same problem, tried Refresh, same problem. What gives, I'm being forced to use Chrome for now, if I can't get this fixed firefox is down the road

WOW what's with F/F Worked fine yesterday, last week, last month, haven't changed anything. Today I opened it up and tried a Google search (www.google.com and I live in Canada) I get this id Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to www.google.com because this website requires a secure connection. www.google.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. https://www.google.com/search?client=firefox-b-d&q=help Peer’s Certificate issuer is not recognized. HTTP Strict Transport Security: false HTTP Public Key Pinning: true Certificate chain: <pre><nowiki>-----BEGIN CERTIFICATE----- MIIDcjCCAlqgAwIBAgIQEIbZHWt0hJtK/XuqqBnkmzANBgkqhkiG9w0BAQsFADAj MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMjAxMDEyMTU0 MDE5WhcNMzExMDEyMDg0MDE5WjAZMRcwFQYDVQQDDA53d3cuZ29vZ2xlLmNvbTCC ASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBANJtODVCQ7UHemGuwZ/SNFPZ RstVWSM4KLtjbZHiRqSEchz6nH+IhX06SunvhU1ugnGbSpUanczL66STLqPo78X8 ULdgNuN1tCopCafmLjOgy3t6aZshA/sdItyKe12uowUhu+KqVn9FeC16sgk2uKJJ CER6fHNDSe+Xhu6X2bNdCPUhV0ECfKfBPPuK6oLVdunICBaTXIx1+zAv3fknlX85 Ml+8u7CGm2fwCKCkMgYWMDPAcaVruInf+9J6u/TzzDsPqb+XTtcXyiS1SYJwtsde UpMCGEvbQYzjLDdDARraqv35HIG4JHdD99Ib1/f1pq0inbGiu04AU9zYJ/JG8HUC AwEAAaOBqzCBqDATBgNVHSUEDDAKBggrBgEFBQcDATAMBgNVHRMBAf8EAjAAMA4G A1UdDwEB/wQEAwIFoDAzBgNVHREELDAqgg53d3cuZ29vZ2xlLmNvbYIMKi5nb29n bGUuY29tggpnb29nbGUuY29tMB8GA1UdIwQYMBaAFO1CfY69MTD1W8AQSto+B6Rf KWxPMB0GA1UdDgQWBBTU5XfgWojgi1toVWSA3LQYDOZB7jANBgkqhkiG9w0BAQsF AAOCAQEAGxnbO0DVv45PjYlsBo6l7Z+K6BLE2n9JKUTL1Xk9H3RncUwjtAtoK2vb N2BRKUU942sgdtu131/xwQmjff+l3X90XIbWJqVFXUcTetIhDOSgFIyUAfvudPYw 7u4mUPDn02mWNHvb/SZObVHNwE/fjKWuV/2XxPy+LnHdGxneXicdGcaA6MPNZzGf RC2lcDoyMth5W91OEfov2FSdyoHrLz5vYxHyb9nK8FIRlNJ9P7jKQOPzmFg2rTMk EO0BYpRqrraJTVfUBRLbUE9KaZFNoU6y8fy1JOT0vg/YOavQGuJAJFWd+6ktDVpe Cdr3MYXlElKpTwxTx3EsGFadBJ40fA== -----END CERTIFICATE----- </nowiki></pre><br> Then I try and load Amazon... Did Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to www.amazon.ca because this website requires a secure connection www.amazon.ca has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. https://www.amazon.ca/?tag=hydcaabkg-20&hvadid=231015454001&hvpos=1t1&hvnetw=g&hvrand=2219692390578281202&hvpone=&hvptwo=&hvqmt=e&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9001437&hvtargid=kwd-13273016&ref=pd_sl_7na9ri0ehg_e&hydadcr=20060_10090745&gclid=CjwKCAiAwZTuBRAYEiwAcr67OUKH_X-Ol94xgBW0zteIYObKQqwNwT8aRmjP4CtZkr8PCILCcfvrzhoC8aMQAvD_BwE Peer’s Certificate issuer is not recognized. HTTP Strict Transport Security: true HTTP Public Key Pinning: false Certificate chain: <pre><nowiki>-----BEGIN CERTIFICATE----- MIIDbjCCAlagAwIBAgIQQhMD0ChvzK5P+b9TnEWbLDANBgkqhkiG9w0BAQsFADAj MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMjAxMDEyMTYw NTM2WhcNMzExMDEyMDkwNTM2WjAYMRYwFAYDVQQDDA13d3cuYW1hem9uLmNhMIIB IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAo+LytS3SkDxmXUxYZZedgrNX 8JrjFoWkv8Xzv91EPqzmIYxQTdU1L7AurKjbwbZDRHjzCNyY3n5UYxxoW9Vyaasp ff1slTCkLT5e2YaQL3DulhzzwHsLkOlCyvLw0ytL0BnjM3mdOaEUjKButDH9KNrF akQ7Edi6DNaf/nhTZIdm1bqIcuk3xPqKYa6RL6IJ31/Da6ECkbm1ax7X4TVIq9Wd gHhMd44e2SgHdFg5svcynK+ZvemVERNzDz5yXpACZ6E6HAEyzA4rvXLim45ePLB5 gzZdBrkf13PTobN+YbdZMTqToCrBnC8UyOOor4mbyjqMcz95+/RfTLrosQsoUQID AQABo4GoMIGlMBMGA1UdJQQMMAoGCCsGAQUFBwMBMAwGA1UdEwEB/wQCMAAwDgYD VR0PAQH/BAQDAgWgMDAGA1UdEQQpMCeCDXd3dy5hbWF6b24uY2GCCyouYW1hem9u LmNhgglhbWF6b24uY2EwHwYDVR0jBBgwFoAU7UJ9jr0xMPVbwBBK2j4HpF8pbE8w HQYDVR0OBBYEFO+y+uFkj43aITbbWjpO8ESnKlynMA0GCSqGSIb3DQEBCwUAA4IB AQAsMJ/mnqm+HKAppLS7coHngDhIjqaUZelreLnXZ29+RxNzsJp+Sat6cQR6oFP+ p9imcSz55x/Jt4viN5RjpQy0J8knyc+96Q9eI4itgIbm7Nkr81x5cLVL/6VFMgMl VRyoF/6NQhRhu1pfHSBS8/HgRLQDEQyhnIflEAJP+9dDhejymAjMlzz8PmO4oxAP 8ieXKnzSN+dw0reKdfWzTTnilOjAOwYGxKKd9JcPXCS+j8KYjHkuAClCusx1H6Yg 6Xjf64rXklZmtdkRtJcnAi9YjlhCBxb13CUxDSgcO51EICekCfRKgwuyY9DFmCGy y4pScL9ZjCh7E9xgMMSnHBZd -----END CERTIFICATE----- </nowiki></pre><br> So then I try and connect to my email server https://webmail.shaw.ca/ Hit login shows this in the address bar https://webmail.shaw.ca/#1 and it just sits there. . . . . . nothing, totally useless Did a full antivirus scan with Defender and then Trend House call, nothing Went to my wife's laptop that is identical and everything works fine. Loads fine So I uninstalled Firefox reinstalled and same problem, tried Refresh, same problem. What gives, I'm being forced to use Chrome for now, if I can't get this fixed firefox is down the road

Modified by cor-el

Chosen solution

Something is intercepting your connection and presenting fake site certificates. Start with the following setting, either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Set "No proxy" then click OK.

Any improvement?

Read this answer in context 👍 0

All Replies (10)

more options

Chosen Solution

Something is intercepting your connection and presenting fake site certificates. Start with the following setting, either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Set "No proxy" then click OK.

Any improvement?

more options

Thanks jscher2000, That solution seams to have worked, everything is working now. Should I leave the settings the way they are now with no proxy ticked, or will I be open for trouble. I guess the bigger question is why is this happening? Should I run a different virus scan or try another checker. Like I said before I've done nothing to change any of the preferences in Firefox or changed any of my Defender preferences. Melware? Spyware? Dinnerware? I give up But anyways, Thanks again for your quick help, I really do appreciate it. Ian

more options

And while I'm groveling :-) I have had this problem for 3 or 4 months now and tried several fixes suggested by Moz://a users but with no success. Every time I open FF it opens to half window not maximized. Once its open I can maximize it and continue on Then when I close it and open it again, it's right back to the half window. I've tried the (open maximized) option, resized option, like I said before refreshed, reload. Nothing seams to work. Is this a problem not unique me or am I just the lucky one. Ian

more options

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Ian B Dunn said

Should I leave the settings the way they are now with no proxy ticked, or will I be open for trouble. I guess the bigger question is why is this happening?

Unless you need to use a proxy server, No Proxy is good. Otherwise, Firefox usually looks up the Windows-level proxy server setting and follows that. Maybe it's worth checking what is set there (I don't remember where that is stored).

more options

Thanks, I will heed your advice and leave things alone. Thanks again: Ian

more options

cor-el said

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

It took me a couple tries as it wouldn't rename then delete. But after a couple more tries I was able to delete it. Went back and reopened FF and it opened up maximized, closed it and reopened it and it went right back to half window, same as before. Repeated the steps a couple more times with the same result, half window. Any other suggestions? ian

UPDATE: So I tried it a couple more times and the 4th time I deleted the .json file then I deleted it from the recycle bin. I then opened up FF again and it works so far. Will let you know with an update if it keeps working. Ian

Modified by Ian B Dunn

more options

Note that Firefox needs to be closed when you remove xulstore.json or otherwise make changes to files in the Firefox profile folder.

more options

And after I restarted the computer, Firefox is right back to half screen when I launch it. So it is still not fixed.

-( Ian
more options

And yes I completely close down Firefox before I delete the file Ian