Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Potential Security Issue

  • 2 replies
  • 1 has this problem
  • 36 views
  • Last reply by cor-el

more options

I am trying to access a few financial sites and receive the following security error that I am unable to resolve. Something changed with my Firefox settings recently as I was able to access these sites prior.

==============

Firefox detected a potential security threat and did not continue to accountaccess.edwardjones.com because this website requires a secure connection.

What can you do about it?

accountaccess.edwardjones.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem.

Chosen solution

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


You can try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Read this answer in context 👍 0

All Replies (2)

more options

Alarm bells are ringing: financial sites really do need a secure connection.

Can you find an "Advanced" button below that error message? That should open a panel with two useful things:

(1) An error code like SEC_ERROR_SOMETHING which we can look up in the following support article or other threads: How to troubleshoot security error codes on secure websites.

(2) A View Certificate link that opens a new tab where you can look at the "Issuer" details to see whether they indicate an interloper. This is what I see for comparison:


Also, do you get the same code and is there a commonality of issuer information on the other sites giving you problems?

Helpful?

more options

Chosen Solution

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


You can try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Modified by cor-el

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.