Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites loading as if blocking is occuring.

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by markus

more options

Hi,

Since the most recent update, websites are loading as if they are experiencing 'blocking' for example when I go to a certain page nothing loads until the whole website is loaded in the background then it suddenly appears complete. So for a short while I have no idea the link or website I visited is working.

Any suggestions or ideas?

Thanks

Hi, Since the most recent update, websites are loading as if they are experiencing 'blocking' for example when I go to a certain page nothing loads until the whole website is loaded in the background then it suddenly appears complete. So for a short while I have no idea the link or website I visited is working. Any suggestions or ideas? Thanks

Chosen solution

Enhanced Tracking Protection and ad-blocking extensions can often cause this.

To disable Enhanced Tracking Protection on a specific website, 1. Go to the shield icon to the left of the address bar. 2. Toggle Enhanced Tracking Protection off.

Most ad-blockers have an option to turn them off for a specific website. If not, you can turn specific extensions off in about:addons.

If these do not work, try opening in Troubleshoot Mode.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Enhanced Tracking Protection and ad-blocking extensions can often cause this.

To disable Enhanced Tracking Protection on a specific website, 1. Go to the shield icon to the left of the address bar. 2. Toggle Enhanced Tracking Protection off.

Most ad-blockers have an option to turn them off for a specific website. If not, you can turn specific extensions off in about:addons.

If these do not work, try opening in Troubleshoot Mode.

more options

Hi,

Thank you.

The only setting I use are the Firefox ones, so will toggle the enhanced protection off.

thank you.