Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website wont work says must accept 3rd party cookies have tried several things

more options

My bank has a tab that pays money directly its called Popmoney. Up until yesterday it has worked fine. It now says "We're sorry for this error. In order to use this service, your internet browser must accept third-party cookies. Please refer to your browser's online help for enabling cookies in your system. Please try again after you enable the cookies." I have gone into settings and unchecked the box for cookies (all of them)under the enhanced tracking protection....reloaded tabs and restarted browser and restarted computer... it still says the same thing on the bank website. I also have gone on the shield next to the website bar and turned off the protection for this site there as well ... it still says the same thing... I also cleared the cookies and the cache for the site I also have unchecked the Tracking I also have put the website address in as an exception for pop up blockers can anyone help /... is this a glitch in a new update.... I think a new update happened ? please help

All Replies (4)

more options

There is a change in Firefox 96 related to cookies and insecure sites.

See also:

As a workaround for now you can modify this pref on the about:config page to revert this change.

  • about:config => network.cookie.sameSite.laxByDefault = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

I have this exact same problem. Error message says I am not accepting third party cookies, when there is no clear indication that I am not.

Helpful?

more options

And I have tried everything that you have...without success! I found out that my mobile app for my credit union will allow me to access popmoney with no problem. Also, Microsoft Edge has a simple on-off button for accepting third party cookies and it's set to "on" by default. I have learned that recently, resolving a Firefox problem can be a real conundrum, which is unnecessary, as part of the problem is the overly complicated settings menu, that seems to assume that the user is an IT specialist. Not the Firefox I once knew!

Helpful?

more options

scotsman2 said

I have this exact same problem. Error message says I am not accepting third party cookies, when there is no clear indication that I am not.

scotsman2 said

And I have tried everything that you have...without success!

Hi, did you see cor-el's reply? I will expand on that:

Firefox 96 made three changes related to cookies that affect when they will be served to third party servers. Most likely it is #1 on the following list, and it's pretty quick to change a setting to test that.

(1) If the server does not specify the SameSite setting for its cookies, Firefox changed from treating it as SameSite=None (allow serving as a third party cookie) to SameSite=Lax (partially restricts serving as a third party cookie).

Users have reported two different servers with this issue so far:

  1. iCloud: https://support.mozilla.org/questions/1364242
  2. Canvas/Kaltura

(2) If the cookie was set on an HTTPS page, it is not automatically passed to HTTP pages on the same server. In other words, SameSite consider the protocol (scheme) as well as the host name. This is a problem for older sites that use HTTP for most pages but do the login over HTTPS. Example: https://www.reddit.com/r/firefox/comments/s3iych/south_korea_cant_sign_in_to_some_websites_after/

Note: a hotfix was released Friday to revert change #2.

(3) If the server specifies that third party cookies are okay by setting SameSite=None, this is only honored for HTTPS pages, not HTTP pages. I don't know whether this is causing problems on any sites.


How to test whether this is issue #1:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

(C) Double-click the network.cookie.sameSite.laxByDefault preference to switch the value from true to false

I don't know whether that takes effect immediately or whether you need to quit Firefox and start it up again.

Hopefully we will get a better understanding of how to set exceptions in the future so you can benefit from this change while using other sites.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.