Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Unable to play Prime Videos & Netflix Videos

  • 14 replies
  • 1 has this problem
  • 25 views
  • Last reply by cor-el

more options

I'm on the latest version of Firefox, and it's unable to play videos on Amazon.com & Netflix.com. Neither did the one before 96.0. I first saw this on Netflix.com and when the tech started asking questions about my operating system, I knew they had pulled a fast one. Now Amazon.com has done the same thing with Firefox. This browser should be hiding the underlying operating system, because it's not necessary. I can use both websites with Chrome and have no issue. The same version of Firefox is on my laptop, but it has no problems because that thing is on Windows 10.

I won't bother with all the nonsense written about troubleshooting, because this is strictly the functionality of those websites peeking under the browser to check the O.S. Firefox needs to fix this hole immediately! You're messing with my money now. Monopolies shouldn't be able to control our hardware like this; they're not paying for any of it.

Oh, my TV is having a problem with the apps, so I was forced to watch videos with my computer instead. My laptop screen is too small and can't have my booming speakers connected to it. My desktop monitor is 34".

I'm on the latest version of Firefox, and it's unable to play videos on Amazon.com & Netflix.com. Neither did the one before 96.0. I first saw this on Netflix.com and when the tech started asking questions about my operating system, I knew they had pulled a fast one. Now Amazon.com has done the same thing with Firefox. This browser should be hiding the underlying operating system, because it's not necessary. I can use both websites with Chrome and have no issue. The same version of Firefox is on my laptop, but it has no problems because that thing is on Windows 10. I won't bother with all the nonsense written about troubleshooting, because this is strictly the functionality of those websites peeking under the browser to check the O.S. Firefox needs to fix this hole immediately! You're messing with my money now. Monopolies shouldn't be able to control our hardware like this; they're not paying for any of it. Oh, my TV is having a problem with the apps, so I was forced to watch videos with my computer instead. My laptop screen is too small and can't have my booming speakers connected to it. My desktop monitor is 34".
Attached screenshots

Modified by King Ray

All Replies (14)

more options

Hi could, you tell us your Widevine plugin version? You can check that on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. On the right side, click "Widevine Content Decryption Module provided by Google Inc."

Does yours show as version 4.10.2391.0 ?

If you want to try to force a removal and reinstallation of Widevine, try turning off DRM (see the steps in the following article), wait a minute for that to take effect, then turn it back on.

Ref. Watch DRM content on Firefox

more options

By the way, if you want to change how Firefox identifies itself to websites, there is a way to do that.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(3) Click String, then click the + button

Firefox should open an editing field

(4) Paste a Windows 10 string into the field, such as

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:96.0) Gecko/20100101 Firefox/96.0

Then press Enter or click the blue check mark button to save the change.

(5) In the search box in the page, type or paste general.oscpu.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(6) Click String, then click the + button

Firefox should open an editing field

(7) Paste a Windows 10 string into the field, such as

Windows NT 10.0; Win64; x64

Then press Enter or click the blue check mark button to save the change.

Does that fool the sites?

more options

I'll try that a little later and let you know what happens. I changed another switch, but it didn't work. That one looks more logical jscher2000.

more options

jscher2000 said

Hi could, you tell us your Widevine plugin version? You can check that on the Add-ons page. Either:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return
In the left column of the Add-ons page, click Plugins. On the right side, click "Widevine Content Decryption Module provided by Google Inc." Does yours show as version 4.10.2391.0 ? If you want to try to force a removal and reinstallation of Widevine, try turning off DRM (see the steps in the following article), wait a minute for that to take effect, then turn it back on. Ref. Watch DRM content on Firefox

That isn't one of my Add-ons.

more options

jscher2000 said

By the way, if you want to change how Firefox identifies itself to websites, there is a way to do that. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered Firefox should show a bar with the preference name, Boolean Number String, and a + button (3) Click String, then click the + button Firefox should open an editing field (4) Paste a Windows 10 string into the field, such as Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:96.0) Gecko/20100101 Firefox/96.0 Then press Enter or click the blue check mark button to save the change. (5) In the search box in the page, type or paste general.oscpu.override and pause while the list is filtered Firefox should show a bar with the preference name, Boolean Number String, and a + button (6) Click String, then click the + button Firefox should open an editing field (7) Paste a Windows 10 string into the field, such as Windows NT 10.0; Win64; x64 Then press Enter or click the blue check mark button to save the change. Does that fool the sites?

Okay, no that didn't fool either one. I'm still very curious why this isn't happening to Chrome.

more options

Hi

Please can you restart Firefox which should fix this issue.

more options

I restarted Firefox after doing what the other person said. Didn't fix anything.

more options

Make sure you have the latest Widevine version (4.10.2391.0).

  • Tools -> Add-ons -> Plugins

You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests (i.e. only enable XHR via the filter bar in the console and disable all others) in the Browser Console if this doesn't work in case something is blocked as we have seen cases where this origin is blocked via the OS hosts file.

You can also check the Web Console to see if there is more detail available (enable: Errors, Warnings, Logs).

more options

cor-el said

Make sure you have the latest Widevine version (4.10.2391.0).
  • Tools -> Add-ons -> Plugins
You can toggle DRM off/on to see if that makes Firefox (re)load DRM components. You can possibly check the XHR requests (i.e. only enable XHR via the filter bar in the console and disable all others) in the Browser Console if this doesn't work in case something is blocked as we have seen cases where this origin is blocked via the OS hosts file. You can also check the Web Console to see if there is more detail available (enable: Errors, Warnings, Logs).

Oh, so I need to go out and find that add-on? Will do and let you know. The name of this add-on is unclear and not what I'm finding when I search for it. I can tell I grabbed the wrong one when I look at the version. Do you have a link for it?

Modified by King Ray

more options

cor-el said

Make sure you have the latest Widevine version (4.10.2391.0).
  • Tools -> Add-ons -> Plugins

Most frustrating thing about forums is people make assumptions about everything. I don't have this product, it seems to be for Windows 10, and trying to find it is like looking for a needle in a haystack. Interesting you didn't provide a link for it, cor-el.

more options

This problem may have appeared when Javascript was disabled for Firefox. I'm having a heck of a time finding the released version of Google Widevine CDM. Anybody know where I can find it for Windows 7?

more options

The Google Widevine CDM is used on all platforms to play DRM protected media content and is normally loaded automatically by Firefox is it is needed by a website to play this kind of content.

What plugins do you see listed in "Add-ons -> Plugins" (Ctrl+Shift+A; works when an input field doesn't have focus) ?

Did you make sure DRM is enabled ?

Yo7 can check these prefs on the about:config page and make sure they are default (i.e. not bold).

  • media.eme.enabled = true
  • browser.eme.ui.enabled = true

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

cor-el said

The Google Widevine CDM is used on all platforms to play DRM protected media content and is normally loaded automatically by Firefox is it is needed by a website to play this kind of content. What plugins do you see listed in "Add-ons -> Plugins" (Ctrl+Shift+A; works when an input field doesn't have focus) ? Did you make sure DRM is enabled ? Yo7 can check these prefs on the about:config page and make sure they are default (i.e. not bold).
  • media.eme.enabled = true
  • browser.eme.ui.enabled = true
You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Okay, I found it. It's enabled, and the boolean items are true. My version isn't 4.10.2391.0; it's 4.10.2209.1. I don't know how to update it, but did turn the automatic update on.

I swear I shouldn't have to go through all this when that software has been sitting there the entire time without me altering anything. I don't mess with things that I know nothing about.

more options

If you turn DRM off in Settings and wait a minute and turn DRM back on then Firefox should check for an update of the Widevine plugin.