Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stay logged on to the Support Forum?

  • 14 replies
  • 2 have this problem
  • 63 views
  • Last reply by AliceWyman

more options

Using Windows 10 OS Firefox 95.0.2 (64bit) - default browser. Since update to 95.0.2, everytime I want to use the Firefox or Thunderbird Support forum, I'm asked to login before I can respond to any questions. I am a regular helper on the Thunderbird Support Forum. So this is driving me potty :) This can occur if I exit Firefox or awake from sleep mode or at random times whilst I'm using Firefox with Thunderbird Support in a Tab and I may be using Bugzilla.

Note: I'm not using two step.

Menu app icon > select email address > Firefox Account When I select it auto uses the 'Synchronise now' It continually shows 'Logout' - I never need to Login.

I noticed my settings had been altered when Firefox updated. I have reset the about:preferences#privacy Selecting 'Use Custom Settings' 'private browsing mode' is NOT selected. 'remember browsing and download history' is selected. 'remember search and form history' is selected 'clear history when firefox closes' is NOT selected.

My history is looking ok.

I would appreciate some pointers to discover why I'm being logged out of this Support Forum. I want to stay logged on to account.

Using Windows 10 OS Firefox 95.0.2 (64bit) - default browser. Since update to 95.0.2, everytime I want to use the Firefox or Thunderbird Support forum, I'm asked to login before I can respond to any questions. I am a regular helper on the Thunderbird Support Forum. So this is driving me potty :) This can occur if I exit Firefox or awake from sleep mode or at random times whilst I'm using Firefox with Thunderbird Support in a Tab and I may be using Bugzilla. Note: I'm not using two step. Menu app icon > select email address > Firefox Account When I select it auto uses the 'Synchronise now' It continually shows 'Logout' - I never need to Login. I noticed my settings had been altered when Firefox updated. I have reset the about:preferences#privacy Selecting 'Use Custom Settings' 'private browsing mode' is NOT selected. 'remember browsing and download history' is selected. 'remember search and form history' is selected 'clear history when firefox closes' is NOT selected. My history is looking ok. I would appreciate some pointers to discover why I'm being logged out of this Support Forum. I want to stay logged on to account.

Modified by Toad-Hall

All Replies (14)

more options

Hi there I have found a link that might help you with this problem I hope this helps let me know if it doesn’t and I’ll find another way but here’s the link

https://support.mozilla.org/en-US/questions/1227940

Wes

more options

I'll give it a go, but obviously Firefox has been resetting a load of settings. It looks like I'm switching something on which I would not choose and then switching most of it off again just to stop auto log outs.

Previously, I did not select 'Clear History When Firefox Closes. ', so the default setting to 'clear active logins' when Firefox closes should not have been enabled anyway.

Now, I've selected 'Clear History When Firefox Closes. ' and then unchecked most except 'Cache' and 'Form And Search History'

That basically means if you do not select 'Clear History When Firefox Closes' - leave it unchecked, then the settings it contains are all active by default which makes no sense at all. Makes you wonder what developer thought that unselecting that option meant all settings it contains would be active yet the 'Settings' button is greyed out and disabled. Any how, we'll see what it produces and I'll report back with findings.

Thanks for info.

more options

Your welcome message me if it works

more options

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
more options

You can also try to keep a (pinned) tab open to make Session Restore store the cookies and login state.

more options

I am following this topic as I have exactly the same issue with the same SUMO web site only and less frequently with bugzilla. I posted my request in the contributor forums because I felt the issue must the kitsune and the firefox logins.

My differences are Firefox Daily, not 95.

	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0
more options

cor-el said

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you <snip>
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"

I was also getting logged out of the Mozilla Support site (and Bugzilla) in Firefox. This was happening to me long before 95.0.2 was released, in multiple versions of Firefox as I posted here in the contributor forum. I went to the Firefox menu fx89menuButton -> Settings -> Privacy & Security Cookies and Site Data -> [Manage Exceptions...] yesterday and set both https://support.mozilla.org and https://bugzilla.mozilla.org to Allow cookies. So far so good.

Here's a screenshot of my Manage Exceptions settings, in case it helps others:

Fx95CookieExceptions

Modified by AliceWyman

more options

The point is this: I never had the problem until the latest update, so obviously something was changed by Firefox in latest update.

This morning I booted up computer, accessed this forum and I was able to place a comment without needing to logon with Firefox Account. So altering the settings worked.

That means: select 'Clear History When Firefox Closes. ' even if you do not want this to occur then in the enabled 'Settings' button uncheck everything except 'Cache' and 'Form And Search History' click on OK In fact you could disable everything in the 'Settings' if you want just to make the selected 'Clear History When Firefox Closes' alledgedly none functional.

Conclusion: if you do Not select 'Clear History When Firefox Closes. ' because that is precisely what you require, Firefox still activates the disabled setting 'clear active logins' when Firefox closes. You cannot uncheck 'clear active logins' because it is hidden behind a disabled 'Settings' button. That means there is a bug and I've reported it. https://bugzilla.mozilla.org/show_bug.cgi?id=1748179

more options

Matt said

I felt the issue must the kitsune and the firefox logins.
#metoo.

Modified by TyDraniu

more options

Active Logins would normally be about sessions that use basic HTTP Authentication like FTP sites used in the past (i..e a special popup to enter a username and password), so I'm not sure why this would work, but the way cookies are handles via two different settings ("Clear history when Firefox closes" and "Delete cookies and site data when Firefox is closed") is not very clear and there is also the "Redirect Tracking Protection" feature to purges cookies from not visited third-party websites. Creating a cookie allow exception and clearing all current cookies for this website should work if thee support this via a cookie with a future expire date.

more options

Here we have the cookies pre login. And post login.

What I am left with is the Firefox login cookieis a non visited third party web site. Not that I can find any cookies from firefox.com

more options

cor-el said

Active Logins would normally be about sessions that use basic HTTP Authentication like FTP sites used in the past (i..e a special popup to enter a username and password), so I'm not sure why this would work, but the way cookies are handles via two different settings ("Clear history when Firefox closes" and "Delete cookies and site data when Firefox is closed") is not very clear and there is also the "Redirect Tracking Protection" feature to purges cookies from not visited third-party websites. <snip>

The question about Active Logins and cookies that store login status has come up before. See: https://support.mozilla.org/en-US/questions/960425

I edited the Delete browsing, search and download history on Firefox article section, What things are included in my history? to add more information about clearing Active Logins and cookies:


  • Active Logins: If you entered a username and password for a site that uses HTTP basic authentication since you last opened Firefox, that login is considered "active". Clearing this will log you out of all sites that use this authentication method. It will not log you out of websites that use cookies to store login status.

cor-el, l'll wait a bit before marking my revision ready to localize in case other changes are needed.

More information: "HTTP Authentication": https://developer.mozilla.org/en-US/docs/Web/HTTP/Authentication "HTTP Basic Authentication": https://docs.oracle.com/cd/E19879-01/819-3669/bncbo/index.html Clearing Active Logins: Bug 540516 Usability: Allow users to clear HTTP Basic authentication details ('Logout')

Modified by AliceWyman

more options

Well, I can report that it did not last long. Today, I booted up, went to the already opened tab, selected a question and responded - so far all ok. Made a cup of tea, and returned to help more people - guess what - I need to logon to post a comment, so click on the link, click on Firefox Account and login - 3 clicks - did not need to enter anything and now I can post comment in this question.

So now I'm attempting the following:

  • select 'Clear History When Firefox Closes. '
  • then in the enabled 'Settings' button
  • uncheck everything - nothing is selected
  • click on OK
  • then uncheck 'Clear History When Firefox Closes. '

Note: if you subsequently reselect and check the Settings, they remain unselected - but I'm continuing with the settings as per above to see effects.

Modified by Toad-Hall

more options

The https://support.mozilla.org exception I set in Settings -> Privacy & Security Cookies and Site Data -> [Manage Exceptions...] is no longer working for me in Firefox 78esr, 94, 95, 96Beta and 97Nightly, even though I had the exception set in all those versions and profiles. I was no longer logged in to SUMO and had to log back in. I was still logged in to SUMO in Firefox 89, though.

I use SeaMonkey rather than Firefox for most browsing, KB edits and SUMO forum support, so it's not that big of a problem for me. I have never been logged out of SUMO with SeaMonkey