Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox browser shows the SSL Certificate on my businesses website as "not secure."

  • 11 replies
  • 2 have this problem
  • 438 views
  • Last reply by FredMcD

more options

I recently updated the SSL certificate for my business. My Firefox browser indicates the certificate is "not secure." When I navigate to my website using Bing, the SSL certificate shows as being "secure." I'd like the SSL certificate to indicate it is secure using Firefox browsers. Is there something I can do so that when someone lands on my website using Firefox it will correctly show that it is a "secure" site?

Thank you.

G. Borovick

I recently updated the SSL certificate for my business. My Firefox browser indicates the certificate is "not secure." When I navigate to my website using Bing, the SSL certificate shows as being "secure." I'd like the SSL certificate to indicate it is secure using Firefox browsers. Is there something I can do so that when someone lands on my website using Firefox it will correctly show that it is a "secure" site? Thank you. G. Borovick

Chosen solution

Update: with the passage of 24 hours, the "not secure" warning is no longer present when I open my site in Firefox. At this time, the site SSL certificate indicates secure status.

Thank you again for you interest and tips to resolve this issue.

Read this answer in context 👍 0

All Replies (11)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

No problems here with the certificate for this website and the report also looks good.

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

I navigated to the Firefox profile file using the steps provided and changed the file to cert9OLD. I did not see the cert8 db file. I closed the folder, reopened Firefox and my website. It still shows as "not secure" on my PC. I then went back into the profile file. I saw two files: cert9OLD and cert9.

I'm probably missing something. Should I clear cache and see if that works?

Thank you.

more options

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-firefox-did-not-connect

https://support.mozilla.org/en-US/kb/websites-dont-load-troubleshoot-and-fix-errors

What do the security warning codes mean


Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

more options

Who is the issuer of the certificate ?

You can check details about the issuer of the certificate and the certificate chain.

  • click the "Advanced" button on the error page to show more detail
  • click the blue "View Certificate" text to inspect the certificate chain in the Certificate Viewer
more options

Thank you all. I tried the "forget site" option. I continue to get the "not secure" description when I open the site in my Firefox.

By checking the SSL certificate using the suggested SSLLABS tool I can see that the certificate is working as it is supposed to. That was the reason for reaching out.

So I think the problem seems to be with my version of the Firefox browser. Therefore, because the issue is limited to my PC, I am at an end point and will not be pursing the matter further.

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address box.

more options

Do you get an error page with a possible 'Advanced' button that allows to inspect the certificate ?

more options

Chosen Solution

Update: with the passage of 24 hours, the "not secure" warning is no longer present when I open my site in Firefox. At this time, the site SSL certificate indicates secure status.

Thank you again for you interest and tips to resolve this issue.

more options

That's good to hear. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.