Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook fonts/text margins look odd after an update

  • 5 replies
  • 1 has this problem
  • 36 views
  • Last reply by cor-el

more options

After a Firefox update, Facebook messenger fonts and/or text margins changed and started to look unpleasant to read (too narrow line spacing, the text is crammed vertically and background text fields are smaller). Chromium displays the font as before.

After a Firefox update, Facebook messenger fonts and/or text margins changed and started to look unpleasant to read (too narrow line spacing, the text is crammed vertically and background text fields are smaller). Chromium displays the font as before.
Attached screenshots

Chosen solution

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 0

All Replies (5)

more options

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore


[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".
more options

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

I do use the zoom option, but the problem persists on 100%. Site fonts are allowed. From inspecting the fonts, Nimbus Sans is used, which looks like a replacement for the original Helvetica. I increased the line spacing option and it did look right on higher values. Is the wrong line spacing an issue with the browser, or I should tinker with the font itself?

Modified by ratratte7

more options

Tried to force the site to use other fonts (with the Firefox settings), and they all look crammed, whatever font is used.

more options

Chosen Solution

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.