On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extension.json file seems to be corrupting each reboot

  • 6 replies
  • 1 has this problem
  • 89 views
  • Last reply by KaimTime

more options

Hiya, I've been having trouble with my firefox since about a week ago:

The plugin Simple Tab Groups refuses to load & while all other extensions still function correctly besides Simple Tab Groups, I cannot access the extensions page when STG is broken as it also breaks. Not loading any extensions or themes. I've tried firefox with STG disabled & nothing breaks the way it is when STG is enabled. So it's some interaction there.

The only fix I've found is deleting the extensions.json file in my firefox profile folder, but that only works for one session. The moment I close & reopen firefox it appears broken again.

I've already emailed the developer but they havent replied & this seems it could be an issue with Firefox seeing as the extension works fine when extensions.json has been remade.

Here's my 'about:support' info-dump: https://pastebin.com/1FZFudmi

Any help would be appreciated !

Hiya, I've been having trouble with my firefox since about a week ago: The plugin Simple Tab Groups refuses to load & while all other extensions still function correctly besides Simple Tab Groups, I cannot access the extensions page when STG is broken as it also breaks. Not loading any extensions or themes. I've tried firefox with STG disabled & nothing breaks the way it is when STG is enabled. So it's some interaction there. The only fix I've found is deleting the extensions.json file in my firefox profile folder, but that only works for one session. The moment I close & reopen firefox it appears broken again. I've already emailed the developer but they havent replied & this seems it could be an issue with Firefox seeing as the extension works fine when extensions.json has been remade. Here's my 'about:support' info-dump: https://pastebin.com/1FZFudmi Any help would be appreciated !

All Replies (6)

more options

KaimTime said

Here's my 'about:support' info-dump: https://pastebin.com/1FZFudmi

Error, this is a private paste or is pending moderation. If this paste belongs to you, please login to Pastebin to view it.

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

more options

FredMcD said

KaimTime said

Here's my 'about:support' info-dump: https://pastebin.com/1FZFudmi

Error, this is a private paste or is pending moderation. If this paste belongs to you, please login to Pastebin to view it.

fixed it!! should be accessible now

FredMcD said

It’s possible that there is a problem with the file(s) that store the extensions registry. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory. Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. After, restart Firefox. See "Corrupt extension files" +++++++++++++++++++++++++++ You may have to approve the updating once again.

So this fixed it for one session, but upon restarting Firefox? The same issue happens again :(

cor-el said

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Tried this too & it did nothing :((

more options

The Pastebin link still isn't working for me. You can possibly test it yourself in a new Private Browsing mode window.

You can try to open extensions.json in a Firefox tab and check the file for possible errors.

You can try to uninstall and reinstall STG. If STG allows to export/backup its settings then do this.

more options

cor-el said

The Pastebin link still isn't working for me. You can possibly test it yourself in a new Private Browsing mode window. You can try to open extensions.json in a Firefox tab and check the file for possible errors. You can try to uninstall and reinstall STG. If STG allows to export/backup its settings then do this.

weird I have it set to public, maybe it's awaiting being cleared for moderation. I can paste it here if you want instead.

As for reinstalling STG, Just tried that. Exported & imported my settings, relaunched firefox & it's still broken.