Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mapi attachments disappear from moz-mapi folder before email sent, creating send error after update to 91.2.0

  • 3 replies
  • 2 have this problem
  • 43 views
  • Last reply by bpiepho

more options

Hi, We create pdf files within a Filemaker database then send them via mapi to Thunderbird. After an automatic update from Thunderbird 78.14.0 to 91.2.0 an error would occur every 5 or 6 mapi emails sent as follows:

SEND MESSAGE ERROR Sending of the message failed. There was an error attaching Email.pdf. Please check that you have access to the file.

After investigation I finally noticed that on the failed messages the copy of the attachment inside the temp/moz_mapi folder would disappear before I was able to complete the email i.e. fill in who it was going to, add a subject and any further content. On successful messages only after I has sent the email successfully was the attachment deleted from the moz_mapi folder.

This morning I have reproduced the issue on a clean Window 10 Pro computer by installing v78.14.0 (both 32 & 63 bit versions) having all mapi emails sent successfully and then having the issue appear after updating to 92.2.0.

I believe I should create a bug report for this but can anyone shed any light?

Thanks, Dom Morgan.

All Replies (4)

more options

Is Filemaker 32 or 64 bit, and same for TB 91? I think MAPI works best if both are 32-bit, but if Filemaker is 32-bit, MAPI won't work with TB 64-bit.

https://support.mozilla.org/en-US/questions/1352792

Helpful?

more options

Thanks for your response.

Filemaker is now only available in 64 bit on Windows. In fact Filemaker 64 bit has been working well with 32 bit Thunderbird for about 6 months and only after the automatic update to 32 bit TB v91.2.0 last week did the problem arise. I then installed 64 bit v 91.2.0 which had the same issue. I then tried 64 bit v 78.14.0 on a different computer and that did not have the problem so it does seem to be something that changed in v 91. On this other computer using v 91.0.1 or v 91.2.0 both exhibited the issue.

Often with older (i.e. v78 and older) versions of TB many of the pdf files would build up in the moz-mapi temp folder with the pdf name plus extra numbers. That doesn't seem to happen with v91.

Helpful?

more options

I see you have submitted a report: https://bugzilla.mozilla.org/show_bug.cgi?id=1735601 so we shall see if there are any comments from the developers.

Helpful?

more options

Since the 91.2.0 (32-bit) upgrade installation on my Windows 10 PC, I have had nothing but problems composing and/or sendign or forwarding messages with PDF files attachements. First day IO could not open a pdf file attacment and got you have choosen to open nsmail-1.pdf when the file name is "2021 10 14 New Quercetin - COVID Outcomes.pdf error message asks what should Thunderbird do with this fil - Open with ?? and no option to open with AdobeReader. Sending a message with pdf attachmetns get merror message Sending maessage failed. An error occured while sending mail. The mail server responded <@yahoo.com> invalid address "@yahoo.com" please chace and try again. Other messaeges sent with the same pdf aattachments with several recipients having @yahoo.com as the mail address and the messages appaera to go through - i.e. no errors - try again. Several days ago got a help suggestion that to open a pdf attachment durin a message compostion process the file name could not have spaces and needed a dash sympol replacing the spaces.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.