Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird suddenly uses 24hr time format

  • 3 replies
  • 2 have this problem
  • 5 views
  • Last reply by fstjohn1

more options

Within the last few days Tbird has suddenly started using 24hr time format for everything; both message dates and the calendar rather than the desired 12hr AM/PM. I've made no changes and can't figure out how to change it back. Possibly caused by an update to either Thunderbird, Linux Mint or the Linux kernel, all of which occur pretty regularly - can't say. Only update that looks like it could possibly be causing it is tzdata update from 2021a-0ubuntu0.18.04 to 2021a-2ubuntu0.18.04 on 2021-10-06.

Thunderbird 91.2.0 ubuntu-snap-build-1.0 Linux Mint Cinnamon 19.3 Kernel 5.4.0-87 generic System locale is en_US.UTF-8

Chosen solution

After going through rolling back to 78.14 I managed to get 91.x to display message date / time correctly in Kubuntu 20.04, something Thunderbird should have done by default. I'm supposing this will work in other Linux types.

I found that 91.x has added additional preferences support via the config editor. Those are found about half-way down the page at: https://support.mozilla.org/en-US/kb/customize-date-time-formats-thunderbird

The preference I needed was: intl.date_time.pattern_override.time_short The preference needs to be added via the config editor rather than changing a value already present. So start Thunderbird and go to Edit > Preferences > General. Click Config Editor at the bottom of the page. The editor will open with a search box at the top. Type or copy / paste your preference chosen from the above link.

This preference must be added as a string. Now what values for the string? About 80% of the way down the page at https://unicode.org/reports/tr35/tr35-dates.html#Date_Field_Symbol_Table is a table of some common pattern examples. For my purposes I entered h:mm a for the string value and clicked the check mark to save. The new date / time format shows after closing and restarting Thunderbird.

Read this answer in context 👍 1

All Replies (3)

more options

Similar date / time format issue here. I'm dual booting Kubuntu 20.04 LTS and Windows 10 professional. Kubuntu recently updated from Thunderbird 78.14 to 91.x and udpdated 91.x twice more. Thunderbird 78.14 properly displayed U.S. date / time in 12 hr. format. Thunderbird 91.x refuses to show correct U.S. 12 hr. date / time format. I do use the Thunderbird profile manager and have separate Kubuntu and Windows profiles.

On my system this is the Linux 91.x version only with incorrect date /time. The 91.x version in Windows 10 has correct date / time format.

On a related note, going back to 78.14 was somewhat aggravating. Once one updates to 91.x and opens the mail simply reinstalling 78.14 produces an error about e-mail having been used in a newer format and possible preference changes and requiring creation of a new profile.

I did manage get around the whole new profile issue. Try rolling back at your own risk. Export address book to csv. I deleted compatibility.ini in the profile directory, edited profiles.ini removing the [Instal......] section. Since the reinstall complained about preferences being changed, I saw prefs-1.js and prefs.js in the profile. I deleted prefs.js and renamed the backup prefs-1. to prefs .js.

After that 78.14 would start without whining. I then had to disable and re-enable an extension or two. Address book needed to be imported from the csv file I first mentioned.

Helpful?

more options

Chosen Solution

After going through rolling back to 78.14 I managed to get 91.x to display message date / time correctly in Kubuntu 20.04, something Thunderbird should have done by default. I'm supposing this will work in other Linux types.

I found that 91.x has added additional preferences support via the config editor. Those are found about half-way down the page at: https://support.mozilla.org/en-US/kb/customize-date-time-formats-thunderbird

The preference I needed was: intl.date_time.pattern_override.time_short The preference needs to be added via the config editor rather than changing a value already present. So start Thunderbird and go to Edit > Preferences > General. Click Config Editor at the bottom of the page. The editor will open with a search box at the top. Type or copy / paste your preference chosen from the above link.

This preference must be added as a string. Now what values for the string? About 80% of the way down the page at https://unicode.org/reports/tr35/tr35-dates.html#Date_Field_Symbol_Table is a table of some common pattern examples. For my purposes I entered h:mm a for the string value and clicked the check mark to save. The new date / time format shows after closing and restarting Thunderbird.

Helpful?

more options

Thanks, Webnurse. Worked!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.