Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stopping autoplay videos

  • 4 replies
  • 2 have this problem
  • 54 views
  • Last reply by Terry

more options

How do I stop autoplay and autoloading of videos on yahoo.com news page. Am using Firefox 92, settings-autoplay default for all websites is set "Block Audio and Video". This issue seems to be only on the yahoo.com news page, other sites such as cnn.com. pbs.org do not autoload videos.

How do I stop autoplay and autoloading of videos on yahoo.com news page. Am using Firefox 92, settings-autoplay default for all websites is set "Block Audio and Video". This issue seems to be only on the yahoo.com news page, other sites such as cnn.com. pbs.org do not autoload videos.

All Replies (4)

more options

Allow or block media autoplay in Firefox https://support.mozilla.org/en-US/kb/block-autoplay

more options

Try these settings in about:config. media.autoplay.default = 5 media.autoplay.block-event.enabled = true media.block-autoplay-until-in-foreground = false media.autoplay.allow-extension-background-pages = false media.autoplay.blocking_policy = 2

more options

I'm still unable to block media autoplay, even after changing to the recommended settings through about:config. After each Firefox update, more and more sites are able to subvert the autoplay block. Common sites are Yahoo News and The Hill, along with numerous state and local news sites.

more options

I have a link to a local Yahoo news site. Can you provide the url of the one you are using?