Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to set zoom level for individual pages (automatically)

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by doritos

more options

So for extra security, I recently tried tweaking the about:config as suggested here: https://wiki.mozilla.org/Privacy/Privacy_Task_Force/firefox_about_config_privacy_tweeks.

Everything turned out ok, except the automatic zoom level memory function for each web page switched off. How do I switch it back on?

Many thanks!

Chosen solution

Did you really apply all the pref changes made on the Wiki page ?

I assume that you are referring to enabling "Resist Fingerprinting" about the zoom problem. If you enable a feature like suggested on the Wiki page then you should be fully aware of its consequences as in this case it makes a lot of changes to Firefox. As you noticed, this disables site specific zoom settings. It also places you in the UTC timezone and modifies the user agent to Firefox 91 on Windows 10 and your screen dimensions are rounded to the nearest 100px as the most noticeable changes. It is usually not worth the trouble to enable this feature permanently.

You should consider to undo other changes suggested on the Wiki page as well as you likely forget about them and this can lead to confusing behavior on websites and cause malfunctioning in some cases.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Did you really apply all the pref changes made on the Wiki page ?

I assume that you are referring to enabling "Resist Fingerprinting" about the zoom problem. If you enable a feature like suggested on the Wiki page then you should be fully aware of its consequences as in this case it makes a lot of changes to Firefox. As you noticed, this disables site specific zoom settings. It also places you in the UTC timezone and modifies the user agent to Firefox 91 on Windows 10 and your screen dimensions are rounded to the nearest 100px as the most noticeable changes. It is usually not worth the trouble to enable this feature permanently.

You should consider to undo other changes suggested on the Wiki page as well as you likely forget about them and this can lead to confusing behavior on websites and cause malfunctioning in some cases.

Helpful?

more options

cor-el,

Thank you so much for your super helpful response!

I just switched back the "Resist Fingerprinting", and it resolved the zoom issue. Yes, I did change everything on wiki after reading a blog about security, without understanding what the changes meant.... I will now have to switch everything back... = (

Anyway, lessons learned. Thank you once again!!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.