Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 37 iOS always opens new tab instead of opening last visited

  • 5 replies
  • 1 has this problem
  • 138 views
  • Last reply by James

more options

Latest update broke usability of Firefox. Firefox no longer remembers which tab I was on before I moved away from it. It’s opening a new tab and don’t even get me started on the button movements.

There should be some minimum usability studies a product must do so that they don’t mess up too badly.

Chosen solution

I started using DuckDuckGo browser. Quite wonderful. It seems like Firefox product decisions are not based on doing it right by the user. And they have lost me as a ussr.

Read this answer in context 👍 0

All Replies (5)

more options

I have this problem too. It seems that it is now a 'feature' so as not to distract you when opening the browser again(?) I feel this is going the way of all other software programs and making changes for the sake of it. Could it be possible that if I quit the browser on a tab, I might want to go there when I reopen, instead of yet another programmer deciding what I should have? At least let us turn this wonderful 'add-two-more-stages-to-get-to-where-we-were' feature off!

Helpful?

more options

Chosen Solution

I started using DuckDuckGo browser. Quite wonderful. It seems like Firefox product decisions are not based on doing it right by the user. And they have lost me as a ussr.

Helpful?

more options

This is a disaster. The designers sabotaged Firefox

Helpful?

more options

Go to Settings > About Firefox > Tap 5 Times > Debug: Toggle Start at Home: ON

I found the above workaround in another thread, works flawlessly.

Was so annoying, I ended up with 25+open tabs before I realized they opened automatically every time I launched Firefox in ios.

Helpful?

more options

I haven’t used Firefox v37 for iOS, but v40 (on iOS 15) gives you the option to disable this. (I agree, very questionable design decision to default to.)

Go to Settings > Home Page, and under “Opening Screen” select “Last Tab”.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.