Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks CSS

  • 11 replies
  • 1 has this problem
  • 22 views
  • Last reply by jscher2000

more options

Why are vertical spaces different in my bookmarks from my personal bar, the lateral panel and the library window ? How to fix it, as I want everything same ? I'm unable to take a capture of my personal bar where vertical spaces are bigger than elsewhere.

Chosen solution

I found solution : userChrome.css must be into /home/alan/.mozilla/firefox/mafjaoe.default-release/Chrome/userChrome.css instead to be in /home/alan/.mozilla/firefox/mafjaoe.default/Chrome/userChrome.css like falsely explained in the link I found.

Read this answer in context 👍 0

All Replies (11)

more options

Are you using custom CSS in a userChrome.css file? Firefox 92 changed the styling to Bookmarks Toolbar folder drop-downs, so you need to add a new line to your rules to override a minimum height (it's the one where the comment says v92):

https://www.userchrome.org/firefox-89-styling-proton-ui.html#menuspacing

Helpful?

more options

Hi, thank you for your answer. No I don’t use a custom CSS file on current PC like I did on Mac. I forgot about it. Incredible users must know CSS to get rid of bugs. Maybe I should try to also use it to restore tabs that look like tabs instead to look like buttons. OK for now I presume I should restart Firefox to see changes…

Helpful?

more options

userChrome.css on PC is same as Mac, except that if you had your file for a long time, Firefox 69 added a new step to trigger Firefox to look for the file at startup (step #6 on the old list): https://www.userchrome.org/how-create-userchrome-css.html

Helpful?

more options

Yes I already found how to create this file. But I believe issue comes with round corners (again to look like buttons) which don’t exist in Library window and lateral bar.

Helpful?

more options

The new style has round corners, yes. I'm not sure whether you are saying you want to square them off, or those cause the problem. ??

This is the intended effect of the rule I linked to earlier ("before and after"):

Helpful?

more options

Sorry I tried that but changes seem not applied. However I emptied Firefox cache.

Helpful?

more options

The most common reasons for a problem with a new userChrome.css setup are:

(A) In about:config, toolkit.legacyUserProfileCustomizations.stylesheets not set to true (this takes effect at your next startup)

(B) chrome folder is in the wrong location, for example:

  • in \AppData\Roaming\Firefox\Profiles (outside of the current actual profile folder)
  • in \ProgramData\Mozilla\updates\308046B0AF4A39CB (this is a different Open Folder button on the Troubleshooting Information page)

You can retrace your steps from the Troubleshooting Information page, Profile Folder row.

(C) userChrome.css file has an extra extension (e.g., userChrome.css.css or userChrome.css.txt) or the "U" is upper case or the "C" is lower case

If your OS hides some file extensions, like Windows, change the system setting so you can see the true, full file name + extension: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Helpful?

more options

OK, I'm running Linux Mint but the file is at right place with right extension. Right location under Linux is explained there And this its content : /* Frank edited file - you are good to go...*/

/*

* Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

/*** Tighten up drop-down/context/popup menu spacing (8 Sep 2021) ***/

menupopup:not(.in-menulist) > menuitem, menupopup:not(.in-menulist) > menu {

 padding-block: 0px !important; /* reduce to 3px, 2px, 1px or 0px as needed */
 min-height: unset !important; /* v92.0 - for padding below 4px */

}

root {
 --arrowpanel-menuitem-padding: 4px 8px !important;

}

But vertical spaces between my bookmarks are still big. I will lokk at this tomorrow because it's now full night in Brussels.

Helpful?

more options

I finally succeeded to take captures from issue.

Helpful?

more options

Chosen Solution

I found solution : userChrome.css must be into /home/alan/.mozilla/firefox/mafjaoe.default-release/Chrome/userChrome.css instead to be in /home/alan/.mozilla/firefox/mafjaoe.default/Chrome/userChrome.css like falsely explained in the link I found.

Helpful?

more options

Glad you found that. Everyone's profile folders have different names, so the Troubleshooting Information page is the best place to confirm yours.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.