Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox ignoring PDF setting

  • 7 replies
  • 1 has this problem
  • 453 views
  • Last reply by Terry

more options

On Monday (8/16/2021) I started Firefox and all PDF links opened in its viewer. This was strange since I always have these files set to open in a third party viewer since I have to view the files while using Firefox to search related data. I checked the settings and they were set properly. I tried changing the settings to other options as well as other readers and none of them work.

I went on line and tried ever suggestion that I could find without any luck. I have reset Firefox to it original state and the issue continues.

Any help would be greatly appreciated.

Carl

On Monday (8/16/2021) I started Firefox and all PDF links opened in its viewer. This was strange since I always have these files set to open in a third party viewer since I have to view the files while using Firefox to search related data. I checked the settings and they were set properly. I tried changing the settings to other options as well as other readers and none of them work. I went on line and tried ever suggestion that I could find without any luck. I have reset Firefox to it original state and the issue continues. Any help would be greatly appreciated. Carl

Chosen solution

Apologies. My last response was from my cell as I was away from the computer.

The https://www.copyright.gov/circs/circ61.pdf does work properly

Here is one of the links that is not work since Monday. I wonder if there was a Windows update the is causing the problem.

file:///C:/Manuals/Digital/MX%202300N%202700N/MX%202300%202700%20Service%20Manual.pdf

Truly, many thanks for your help

Read this answer in context 👍 0

All Replies (7)

more options

Hi Carl, what is your current PDF handling instruction on the Settings page? By default, after a Refresh it will be set to "Open in Firefox". (View PDF files in Firefox or choose another viewer)

Does the behavior differ between sites? For example, does this one follow instructions: https://www.copyright.gov/circs/circ61.pdf

more options

Thanks for the quick response

I currently have Firefox set to ask what to do but it still opens the file in the internal reader without asking.

As far as I can tell it is doing it on all sites. The main one is a html page on the computer itself with links to various PDF files.

more options

chellner55 said

I currently have Firefox set to ask what to do but it still opens the file in the internal reader without asking. As far as I can tell it is doing it on all sites.

Did the Copyright Office link open in the viewer automatically, it didn't trigger the download dialog?

The main one is a html page on the computer itself with links to various PDF files.

Does the HTML page have file:/// links or https:// links? With https:// links, the web server informs Firefox of the content-type of the file. With file:/// links, hmm, I assume Firefox uses the .pdf file extension to decide whether it can open the content.

more options

Chosen Solution

Apologies. My last response was from my cell as I was away from the computer.

The https://www.copyright.gov/circs/circ61.pdf does work properly

Here is one of the links that is not work since Monday. I wonder if there was a Windows update the is causing the problem.

file:///C:/Manuals/Digital/MX%202300N%202700N/MX%202300%202700%20Service%20Manual.pdf

Truly, many thanks for your help

more options

Upon further research...

There was a patch in Firefox 91 for file:/// HTML pages linking to file:/// PDF documents

There was a bug in the file => file situation where "Always Ask" led to a broken dialog. As a quick fix, the built-in viewer is always used in Firefox 91.

There is a bug on file requesting to rewrite the fix so that external applications can still be used as the default (1726501). I don't know whether that will get traction, but...

Discussion on that bug mentions the option to completely disable the built-in viewer using a preference if you already prefer to always use an external application:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs.disabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false (enabled) to true (disabled)

Does that solve it for you for now?

More info on about:config: Configuration Editor for Firefox.

more options

It worked perfectly! Thank you so much. This whole week has been so infuriating. Have an absolutely wonderful weekend.

more options