Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

wedsites not displaying properly

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

all the websites look weird. I've included a screen shot of youtube for reference. Disabling add-ons didn't fix the problem. I uninstalled Firefox and reinstalled it but that also did not fix the problem. I haven't tried deleting my user data because it's a bit of a hassle to get it all back. Let me know if there are some other things I can try.

all the websites look weird. I've included a screen shot of youtube for reference. Disabling add-ons didn't fix the problem. I uninstalled Firefox and reinstalled it but that also did not fix the problem. I haven't tried deleting my user data because it's a bit of a hassle to get it all back. Let me know if there are some other things I can try.
Attached screenshots

Chosen solution

This could be a problem with High Contrast Mode on Mac.

See "New" in the release notes.

Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.


Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

This could be a problem with High Contrast Mode on Mac.

See "New" in the release notes.

Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.


Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.