Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Your organization controls this browser

  • 11 replies
  • 1 has this problem
  • 64 views
  • Last reply by firefox1556

more options

Hi, I have tried all day trying to get rid - of SaveFrom.net Helper - no luck. Latest Firefox running on latest Win.10. So frustrating, tried all sorts of tricks and nothing works Cheers,

GregT

Modified by Chris Ilias

Chosen solution

Re-installed Firefox, that fixed it Thanks, GregT

Read this answer in context 👍 0

All Replies (11)

more options

Hello Greg! So what happened to SaveFrom.net? I see it is an online video downloader. So what seems to be the exact issue? You can't close the tab? You screen is frozen?

Please respond asap so I may help you. Thank you!

Kind regards,

Bithiah

Modified by Chris Ilias

Helpful?

more options

Helpful?

more options

Bithiah thank you for your reply. SaveFrom.net Helper hides in Bookmarks Toolbar. I can remove it but it keeps coming back. I have checked in Add on manager in Extension, Plug ins nothing, neither listed or enabled, so not there. I have checked program Files to uninstall = nothing also. Did get something in reg edit ( Window +R keys) where I found the following wording "Your organization controls this browser". Thought I had deleted it - No such luck. Regards, GregT

Modified by Chris Ilias

Helpful?

more options

Hello Greg!

Well if you're computer is monitored by whatever organization you're under, you cannot permanently delete the bookmark. The reason is some settings are managed by your organization and a message appears when you're trying to change your settings on the computer. Your organization needs to verify what you're doing is right and legal in order to delete SaveFrom.net helper bookmark.

For example, my friends computer is currently controlled by his company and if he want to install or uninstall something (permanently) he can't unless the administrator of his company enable him to do so. Hope that makes sense.

Please respond so that I may fix your problem. Thank you!

Kind regards,

Bithiah

Modified by Chris Ilias

Helpful?

more options

Bithiah, Not part of any organization. Private home computer called "Work Station". Never have had a problem installing or uninstalling

about:policies#active? How do I find this Greg T

Helpful?

more options

Active Policy Name Policy Value AppAutoUpdate true Bookmarks Title "SaveFrom.net Helper" URL "https://savefrom.net/" Favicon "https://savefrom.net/favicon.ico" Placement "toolbar" DisplayBookmarksToolbar true ExtensionUpdate true

Modified by Chris Ilias

Helpful?

more options

You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\
  • HKEY_CURRENT_USER\SOFTWARE\Policies\Mozilla\Firefox\

Note that the mere presence of the "Mozilla\Firefox\" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\

See also:

Helpful?

more options

Hi, Checked Registry as you suggested. No luck, Bookmark still keeps coming back as if by magic? - GregT

Helpful?

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

Helpful?

more options

Chosen Solution

Re-installed Firefox, that fixed it Thanks, GregT

Helpful?

more options

I'm also fell victim to my curiosity, but resolved the issue without reinstall.

gtcountry said

Active Policy Name Policy Value AppAutoUpdate true Bookmarks Title "SaveFrom.net Helper" URL "https://savefrom.net/" Favicon "https://savefrom.net/favicon.ico" Placement "toolbar" DisplayBookmarksToolbar true ExtensionUpdate true

Another 100% working solution would be to navigate to your Firefox installation directory and to find a directory called distribution (for example: C:\Program Files\Mozilla Firefox\distribution\). There you would find a file called policies.json. After opening it with a text editor, you would see those exact policies forced by savefrom.net (these files do no exist by default; savefrom.net specifically creates distribution folder to become more annoying).

You can either delete contents of policies.json file or just delete distribution folder altogether.

You can find additional information about policies.json here: https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson


Hope this helps someone in the future!

Modified by firefox1556

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.