Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dark Mode quit working exactly when 91.0 updated 8-10

  • 10 replies
  • 2 have this problem
  • 51 views
  • Last reply by jscher2000

more options

v91.0 dated 8-10, caused all Dark Mode add-ons to stop working, it stopped exactly when the update was installed. Also, dailog boxes do not accept entry... seems this update messed up a lot of funcionality Anyone see this?

I Box to check: Email me when someone answers the thread, does not allow input to the check box


Bill

[Personal information removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

Chosen solution

Hi Bill,

> 1) Did turn off contrast in macOS

Sorry to hear that didn't help, turning off Increase Contrast seems to be the most effective thing so far

> 2)browser.proton.enabled set to False

Please set that to true

> 3)Could not locate "Fonts and Colors" Click the "Colors Button", Set to Never, issue finding the Button

On the Settings page?

See also: Disable high contrast mode in Firefox

> 4) browser.display..document_color_use = Needs response: Boolean - Number - String

There's only one dot after display.

Read this answer in context 👍 0

All Replies (10)

more options

Hi Bill, the checkbox issue might be caused by having set browser.proton.enabled to false in an earlier version of Firefox. It is causing problems with checkboxes in Firefox 91.

But regarding the dark theme:

The release notes for Firefox 91 mention this Mac-specific change: "Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS." Is it possible you have that setting?

If so:

If that setting isn't essential, you could turn it off.

If you prefer to keep it, here are a couple thing to try:

High Contrast preference

When users of Firefox on Windows want to bypass "High Contrast" behaviors triggered by the system, they change a selector on the Settings page (formerly known as Preferences or Options), or you can modify a value in about:config.

Settings

In the "Font and Colors" section, click the "Colors..." button and change the selector below "Override the colors specified by the page with your selections above" to Never and OK that. See: Disable high contrast mode in Firefox.

about:config

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.display.document_color_use and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 then press Enter/Return or click the blue check mark button to save the change.

Here's what the values indicate:

  • 0 => detect preference from system settings (default) to choose between page's colors and user's colors
  • 1 => always use page's colors
  • 2 => always use user's colors

Any difference?


MacOS Dark Theme preference

I can't test it myself, but this might be relevant:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste widget.macos.support-dark-appearance and pause while the list is filtered

(3) If the preference is false, double-click it to switch the value to false

Does that make any difference?

Helpful?

more options

in order:

1) Did turn off contrast in macOS 2)browser.proton.enabled set to False 3)Could not locate "Fonts and Colors" Click the "Colors Button", Set to Never, issue finding the Button 4) browser.display..document_color_use = Needs response: Boolean - Number - String - Typing this in about:Config, does nothing that I see, the default button is Boolean. - pause while the list is filtered, no list presented. This is where I stopped.

Bill

[Personal information removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

Helpful?

more options

Hi Bill, I've noticed that you keep adding your full name and phone number to your forum posts. I want to make sure that you're aware that this is a public community forum. The people that answer questions here are not employees, but users just like you, volunteering their time. The posts here are visible to the general public and indexed by search engines, such as Google.

I've removed your last name and phone number from your posts to protect your privacy. If you don't want them removed, just let us know.

In the meantime, I'm also on mac. I haven't had any issues with dark mode. Is there are an example that you can provide?

Helpful?

more options

jscher2000 (jscher2000)

Sent the instructions for Dark Mode not working... Now what?

Bill

Helpful?

more options

Chosen Solution

Hi Bill,

> 1) Did turn off contrast in macOS

Sorry to hear that didn't help, turning off Increase Contrast seems to be the most effective thing so far

> 2)browser.proton.enabled set to False

Please set that to true

> 3)Could not locate "Fonts and Colors" Click the "Colors Button", Set to Never, issue finding the Button

On the Settings page?

See also: Disable high contrast mode in Firefox

> 4) browser.display..document_color_use = Needs response: Boolean - Number - String

There's only one dot after display.

Helpful?

more options

Same issue here with the latest update Firefox 91.0 Will try these options above but Disabled both dark mode extensions and disabled Firefox and rebooted it fresh and same issue. Can't even see log in boxes on some sites.

Helpful?

more options

lostbydesign said

Same issue here with the latest update Firefox 91.0 Will try these options above but Disabled both dark mode extensions and disabled Firefox and rebooted it fresh and same issue. Can't even see log in boxes on some sites.

Do you use the MacOS setting "Increase Contrast"? If you run Firefox on Windows or Linux, please start a new thread: https://support.mozilla.org/questions/new/desktop/form

Helpful?

more options

I think I found it. I DO have Mac Os settings under Accessibilty on Increase contrast, and in Firefox , I have colors override to 'Never'. What I switched that changed it to dark mode was under Firefox Customize Toolbar. At the very bottom right (easily hidden)under the Tab Themes > DARK. That switched all the toolbars menu and most sites for me. Whew! I thought I'd have to go back to Safari.

I'm running Mojave on a Mac & Firefox 91.0

Helpful?

more options

Ditto. Ditto. Disappointing change in behavior. NO DARK THEME now on cnn.com, or many other regular sites. This was one selection in preferences before and now it is just a lot of trouble, AND most pages are still white!!

Helpful?

more options

Hi nfl1958, are you also using Firefox on MacOS, and are you using the Increase Contrast setting in your MacOS settings?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.