Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps making me sign in and my previous settings for the browser are always reset

  • 4 replies
  • 1 has this problem
  • 9 views
  • Last reply by FredMcD

more options

Hi pals,

It's beginning to annoy me that I have to keep signing into my Firefox account and that I have to adjust setting on the browser, like the language (the default is somehow German and I need it to be in English) and the search engine keeps defaulting back into Google instead of Duckduckgo.

This isn't a normal thing, right?

I've recently switched back to Firefox from Chrome (see: yesterday) and without a break, the above keeps happening which is starting to get to me because I just want to look things up. I've installed the usual Add-ons I had when I was on Chrome like:

  • Dicitionary Anywhere
  • Earth View
  • uBlock Origin

I've read about Disconnect though so that's new for me. So this could be the culprit but other than that, I'm clueless. If anyone has any insight as to what keeps resetting and logging me out, please let me know.

Chosen solution

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Helpful?

more options

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

and whatever else you want.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Helpful?

more options

Thank you for your time, FredMcD :)

Helpful?

more options

The problem is solved, then? Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.