Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Uncontrolled zooming

  • 2 replies
  • 1 has this problem
  • 19 views
  • Last reply by Dale Danell

more options

Using Firefox on a iMac, and the display randomly zooms in when the only input is moving the wireless mouse to the right slightly. I have found no way to return to the normal display without closing out of the Firefox browser, and re-opening. Zoom may be nice for somebody, but never when their is no apparent means to return to the normal display after it was inadvertently triggered for some unknown reason. This is annoying enough to consider utilizing a different browser......

All Replies (2)

more options

Hi Dale, classic zooming can be reset by holding down the Command key and tapping 0 (that's a zero) or clicking the zoom percentage button in the address bar. However, your Firefox might be doing the other kind of zooming, similar to pinching apart on a trackpad. Normally, just moving the mouse wouldn't trigger pinch/magnification zooming; I wonder whether it somehow got connected with a particular gesture.

Could you take a look at these preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste mousewheel*action and pause while the list is filtered

Firefox will display numerous matches. This is my understanding of what maps to what on Mac. The "override.x" preferences are for horizontal scrolling gestures. You could try changing those to 0 (do nothing) and see whether it makes any difference.

PreferenceKeyMac Default Action
mousewheel.default.action--1 => Scroll normally
mousewheel.default.action.override.x---1 => Same as above
mousewheel.with_alt.actionOption/Alt2 => Back/Forward in History
mousewheel.with_alt.action.override.xOption/Alt-1 => Same as above
mousewheel.with_control.action
Ctrl3 => Zoom in/out (reflowing)
mousewheel.with_control.action.override.x
Ctrl0 => Ignore
mousewheel.with_meta.actionCommand3 => Zoom in/out (reflowing)
mousewheel.with_meta.action.override.xCommand0 => Ignore
mousewheel.with_shift.actionShift1 => Scroll normally
mousewheel.with_shift.action.override.xShift-1 => Same as above

(3) Double-click the preference you want to modify and enter the desired value from the following list. After making the change, click the blue checkmark button or press Return to complete the edit.

  • 1 = Scroll normally (ignore the modifier key)
  • 2 = Go Back/Forward in history (dangerous?)
  • 3 = Zoom in/out (reflowing zoom)
  • 4 = Switch to horizontal scroll
  • 5 = Zoom in/out (pinch/magnfy zoom)
  • 0 = Do nothing

Helpful?

more options

Some good information, however to problem still is occurring sporadically. Changed both control.action and meta.action preferences to 0, and the frequency seems to be somewhat less. Interesting the term "mousewheel" is used with the Apple wireless mouse. I think of "wheel" being more associated with Microsoft!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.