Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Update made Youtube videos stop playing properly

  • 4 replies
  • 1 has this problem
  • 16 views
  • Last reply by FredMcD

more options

Since the upgrade to 89, I have a problem with Youtube that, judging by Google results, nobody else on earth has.

If I click on a video, it starts to play normally but as soon as the page finishes loading the video stops and returns to the start of the video. I have to click the play button to get it to play, which it then does without any issues.

The same problem happens when videos are part of one of Youtube's playlists. Video starts, page finishes loading, video stops and goes back to the start.

I've been through too many Google searches, tried about:config changes, policy changes, toggling autoplay in Youtube, installed extensions that supposedly control autoplay. Nothing works.

This was not a problem with 88 when I first had it. When 89 first appeared, I was so frustrated with the wasteful display setup that I uninstalled Firefox and went back to 88; this was when the Youtube issue first appeared. I upgraded back to 89 when I found out how to turn off Proton (because my Bookmark menu shouldn't mostly wasted vertical space) but the Youtube problem persists.

Somebody, please tell me how to fix this.

Chosen solution

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Read this answer in context 👍 1

All Replies (4)

more options

Forgot to mention:

The problem occurs whether signed in to Youtube or not.

The problem does not occur when I test using Internet Explorer, Chrome, or Edge.

Helpful?

more options

Chosen Solution

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

It worked.

Turned out the culprit was an addon called Easy Youtube Video Downloader Express that recently stopped working after more than a year of usefulness. It never occurred to me that more than the downloading ability was deliberately broken by Youtube.

The connection to my Firefox rollback may have been purely coincidence.

Helpful?

more options

As long as the problem is gone, well done. Safe surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.