On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

sending email

  • 1 reply
  • 1 has this problem
  • 7 views
  • Last reply by Paul

more options

Something new is happening - there is a slow and very obstructing problem in sending emails - I can receive emails normally but when I try to reply or to send a message, a yellow bar appears telling me there is a huge content slowing my process and asks me to click 'stop' or 'wait' It now takes 15 - 20 minutes to wait to send a message This has never happened before and has been happening for two days now. Please correct this problem. Thank you

Something new is happening - there is a slow and very obstructing problem in sending emails - I can receive emails normally but when I try to reply or to send a message, a yellow bar appears telling me there is a huge content slowing my process and asks me to click 'stop' or 'wait' It now takes 15 - 20 minutes to wait to send a message This has never happened before and has been happening for two days now. Please correct this problem. Thank you

All Replies (1)

more options

Hi

I am going to close this thread as it appears to be a duplicate of:

https://support.mozilla.org/en-US/questions/1342631