Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Saving my history

more options

Third time of asking - still no resolution! I really REALLY want to save my browsing history. I do NOT want my history to disappear. I now have managed to get Firefox to save 7 days history. How do I get it to NEVER delete my history? Thanks for helping.

All Replies (19)

more options

Enter about:config in the URL bar and give us the value of the places.history.expiration.transient_current_max_pages preference.

Did you follow the Check integrity procedure that FredMcD asked you to do? You didn't even answer with its output.

Modified by TyDraniu

Helpful?

more options

I got this: 112348 places.history.expiration.transient_current_max_pages - 112348

Modified by bewilderbeast

Helpful?

more options

That's quite OK.


Now type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

When done, copy and post the results here.

Helpful?

more options

Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: originFrecencyStats + Recalculated origin frecency stats > Task: vacuum + Initial database size is 5120KiB + The database has been vacuumed + Final database size is 5120KiB > Task: stats + Places.sqlite size is 5120KiB + Favicons.sqlite size is 2336KiB + pragma_user_version is 54 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 112348 unique pages + Table moz_origins has 138 records + Table moz_places has 396 records + Table moz_historyvisits has 359 records + Table moz_inputhistory has 0 records + Table moz_bookmarks has 128 records + Table moz_bookmarks_deleted has 0 records + Table moz_keywords has 1 records + Table sqlite_sequence has 1 records + Table moz_anno_attributes has 3 records + Table moz_annos has 7 records + Table moz_items_annos has 0 records + Table moz_meta has 8 records + Table sqlite_stat1 has 19 records + Index sqlite_autoindex_moz_origins_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_places_originidindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI

Helpful?

more options

This is strange. DB size is very small. Definitely sth wrong is going on here.

Helpful?

more options

DB size small -0 is that where it says 5120KiB ?? Could Windows 7 be the problem? I am switching to W10 this coming week

Modified by bewilderbeast

Helpful?

more options

Yes, 5M is unexpected, usually it reaches 50 - 75MB very fast. Firefox by default starts to remove old history when DB reaches ~75000KiB or in your case 112348 history entries. But you have only 359 records.

I don't know, what keeps your "places" DB so small but I wouldn't blame Win7. However switching to W10 could help.

Modified by TyDraniu

Helpful?

more options

OK, then. Seeing I'm switching to W10 anyway, I'll do that, and then get back to you if need be. Thanks very much for your help. Appreciated. Cheers

Helpful?

more options

TyDraniu said

Yes, 5M is unexpected, usually it reaches 50 - 75MB very fast. Firefox by default starts to remove old history when DB reaches ~75000KiB or in your case 112348 history entries. But you have only 359 records. I don't know, what keeps your "places" DB so small but I wouldn't blame Win7. However switching to W10 could help.

Interestingly, 5120 KiB is 2% of 256 MiB, and if I'm reading the code correctly, that seems to be the cap that Firefox will apply if it can't determine the available disk space.

I had a similar problem a while ago: in my case because my profile is on a dedicated RAMdisk, and Firefox - not having a way of knowing that it has exclusive use of that disk - keeps the places DB accordingly small.

The fix for me was setting places.history.expiration.max_pages to a very large number.

Modified by pg_78

Helpful?

more options

pg_78 said

The fix for me was setting places.history.expiration.max_pages to a very large number.

It would work 2 years ago, but now? Doubtful.

But "drive/storage issues" seems to be a reason of this problem, thanks for answering.

Modified by TyDraniu

Helpful?

more options

This was 2 months ago. I certainly did have the problem before setting that preference - and setting the preference certainly fixed it.

Helpful?

more options

After reading bug 1677969, I agree with you. It could fix it.

Helpful?

more options

The code I'm looking at is here btw: https://github.com/mozilla/gecko-dev/blob/ac36d76c7aea37a18afc9dd094d121f40f7c5441/toolkit/components/places/PlacesExpiration.jsm

Lines 442-452 seem to still read that preference. In fact, what I can't see in that code is anywhere that 'places.history.expiration.transient_current_max_pages' gets set. But I don't know very well how it all fits together, so I may well be misunderstanding it.

Helpful?

more options

Must I do something?

Helpful?

more options

Enter about:config in the URL bar and paste places.history.expiration.max_pages in the Search preference bar. Create a new integer preference with this name and value = 200000. Then restart the browser.

Hopefully it will fix this issue.

Helpful?

more options

If you use external cleanup software like CCleaner then check the settings for Firefox.

Helpful?

more options

I do use CCleaner. I checked: "Clear browser history" is switched OFF, I'm afraid.

Helpful?

more options

I went about:config and pasted: places.history.expiration.max_pages in the Search preference bar but I'm not sure how to do this: Create a new integer preference with this name and value = 200000

Helpful?

more options

Wait! CCleaner! Under: Custom Clean Applications Firefox "Clear Internet History" was checked! I have unchecked it. Fingers crossed

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.