Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to unblock website notifications?

more options

I've accidentally blocked notifications on a website that I cannot use without its notifications. There doesn't seem to be any way to undo this in the notifications settings, and I'm at a loss.

I've accidentally blocked notifications on a website that I cannot use without its notifications. There doesn't seem to be any way to undo this in the notifications settings, and I'm at a loss.

Chosen solution

When you have customized permissions for a site, there should be an extra icon next to the lock. I don't know how to describe it, so here's a screenshot:

Can you find and click that icon and update the notification permission?

Alternately, while you are on a page on the site, call up the Page Info dialog using one of these methods:

  • Command+i (on Windows, Ctrl+i)
  • (menu bar) Tools > Page Info
  • click the lock icon in the address bar, on the drop-down click the > button, then at the bottom click "More Information"

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Send Notifications" uncheck the "Use default" box, and then select Allow to let the site send notifications.

Success?

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

When you have customized permissions for a site, there should be an extra icon next to the lock. I don't know how to describe it, so here's a screenshot:

Can you find and click that icon and update the notification permission?

Alternately, while you are on a page on the site, call up the Page Info dialog using one of these methods:

  • Command+i (on Windows, Ctrl+i)
  • (menu bar) Tools > Page Info
  • click the lock icon in the address bar, on the drop-down click the > button, then at the bottom click "More Information"

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Send Notifications" uncheck the "Use default" box, and then select Allow to let the site send notifications.

Success?