Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access gmail in browser even after update.

  • 5 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

My browser keep preventing me from accessing gmail, sometimes i can get into one account and not the other but now I can't access any of them. Have tried downloading new version but it didn't work.

I also have a problem in that every time I switch on my Mac desktop I have to sign in to firefox again.

Please can someone help. Thanks.

All Replies (6)

more options

Some Firefox 74 users are having problems with websites that require certain types of local storage such as Gmail and Twitter.

The sites won't load in regular windows, but will load in private windows because private windows use memory-based storage and don't need to access the disk-based storage files used in regular windows.

These users also have failures on the second through fourth tests on this page:

If that matches the problem you're having:

Past advice related to that diagnostic result was as follows:

(1) Next Gen Storage Setting

This setting is normally false (off) but in case it somehow got turned on, see the steps in the following article: Some pages or page elements fail to load after updating to Firefox 70.

If that doesn't fix it (after a restart, perhaps):

(2) Flush Data for Problem Site(s)

If you tell Firefox to remove all data for a site, that should include removing its storage folder, as well as its cookies, history, and customized permissions. If you don't want to remove all data, you might be able to fix it temporarily by just removing the "cookies and site data". Here are how to access these options:

(A) Cookies and Site Data

Open the Options/Preferences page using either:

Windows: "3-bar" menu button (or Tools menu) > Options Mac: "3-bar" menu button (or Firefox menu) > Preferences Linux: "3-bar" menu button (or Edit menu) > Preferences Any system: type or paste about:preferences into the address bar and press Enter/Return to load it In the left column, click Privacy & Security

On the right side, scroll down to the Cookies and Site Data section

Click the Manage Data... button to open the "Manage Cookies and Site Data" dialog.

In the dialog's search box, type goog to filter the list. Select the domain(s) relevant to Gmail and click the Remove Selected button. Then click the Save Changes button at the lower right.

Any difference when you try the site again?

(B) Forget About This Site

Open the Library window using Show all History (Ctrl+Shift+h) In the small search box at upper right, enter enough to uniquely identify the site, such as -- we want to avoid accidental misclicks with this feature Right-click a matching history entry and choose Forget About This Site Because Firefox modifies a number of files, this may take some time to run.

Any difference?

If that doesn't fix the problem site(s):

(3) Have Firefox Generate New Storage Folders

This will cause loss of some data saved locally by websites and add-ons.

Open your current Firefox settings (AKA Firefox profile) folder using either

"3-bar" menu button > "?" Help > Troubleshooting Information (menu bar) Help > Troubleshooting Information type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows/File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

"3-bar" menu button > Exit (menu bar) File > Exit Pause briefly while Firefox finishes its cleanup, then right-click the storage folder and Rename to something like storageOLD -- the purpose of renaming instead of deleting is the possibility of reinstating the old folder or mining it for essential data.

Start Firefox back up again. Do sites work again?

more options

michelle.allwood said

My browser keep preventing me from accessing gmail

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

michelle.allwood said

I also have a problem in that every time I switch on my Mac desktop I have to sign in to firefox again.

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file.

more options

Thank you but I can't get it start in safe mode.

It doesn't do anything, no error message just won't open gmail at all. It acts like I haven't clicked on it.

more options

I have managed to enter safe mode and could see that there were lots of red error messages in the scroll. I deleted these and I can now access my main gmail, weirdly still can't access my other account. I can see it but when I click on it just goes to a blank white page, weird. thanks for your help.

more options

I called for more help.