Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashing when opening most Russian websites!

  • 22 replies
  • 1 has this problem
  • Last reply by Danas

more options

I am on Mac OS High Sierra Since about a week literally any Russian website I open just crashes Firefox immediately. I have tried to restart in Safe Mode and clear history - it didn't help. What is happening?! Using Chrome in the meantime (no crash there)

Chosen solution

Do you have a gamepad connected to your Mac because the crash report mentions DarwinGamepadService ?

  • bp-670ffe60-f065-4df5-89cf-52e2a0210404
Read this answer in context 👍 1

All Replies (20)

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 Submitted crash reports, and copy them. Now go to the reply box and paste them in.

Please, Do not post a screenshot ! !

aboutcrashesFx57

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Helpful?

more options

Hi Here are a bunch of the last crashes: bp-670ffe60-f065-4df5-89cf-52e2a0210404 04/04/2021, 15:59 bp-48ddcc8a-2575-47d3-9ee8-dfbea0210404 04/04/2021, 15:45 bp-c988b47a-ad40-44f9-851b-78fed0210404 04/04/2021, 15:45 bp-03d34523-d135-4adc-9a4d-a3a5f0210404 04/04/2021, 15:45 bp-88f4a5c5-f8d2-4af7-947e-718e60210404 04/04/2021, 15:45 bp-d4ae74d8-4b2c-4860-b89a-15da80210404 04/04/2021, 15:45 bp-15f9f070-e5f8-479c-8e1d-623980210404 04/04/2021, 15:45 bp-f8796d89-42c9-4089-b471-b616d0210404 04/04/2021, 15:45 bp-c7334356-9296-4ce8-9747-507d60210404 04/04/2021, 15:45 bp-72c7aa48-0211-487f-8647-629050210403 04/04/2021, 01:01

by the way - indeed most of them were not submitted. how come they were not submitted when I actually did click "sumbmit crash report" after every crash in the reporter window? thanks

Helpful?

more options

Danas said

by the way - indeed most of them were not submitted. how come they were not submitted when I actually did click "sumbmit crash report" after every crash in the reporter window? thanks

That I do not know.


bp-670ffe60-f065-4df5-89cf-52e2a0210404 bp-48ddcc8a-2575-47d3-9ee8-dfbea0210404 bp-c988b47a-ad40-44f9-851b-78fed0210404 bp-03d34523-d135-4adc-9a4d-a3a5f0210404

Signature: CFStringGetCString

Crash Reason EXC_BAD_ACCESS / KERN_INVALID_ADDRESS

Helpful?

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Firefox ESR; Extended Support Release {web link}

Beta, Developer, Nightly versions https://www.mozilla.org/en-US/firefox/channel/desktop/

Install Older Version Of Firefox {web link}


Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

How to Start all Computers in Safe Mode; {web link} Free Online Encyclopedia

Helpful?

more options

Unfortunately nothing helped. I completely deleted Firefox with all the folders, restarted in Safe Mode, performed a clean reinstall, and nothing changed - still all Russian websites crash Firefox immediately! It might sound absurd, but I start thinking of some higher powers involved! :/

P.S. I also tried the Beta version and a previous (86.0.1) version - same result

Modified by Danas

Helpful?

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address bar.

Helpful?

more options

But as I said in the previous comment - I tried to install a completely fresh Firefox - no profile - I deleted all the profiles, it was a blank new Firefox, and still crashing...

Helpful?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia


If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

Please read my replies more carefully - I have already mentioned that I did all that - restarted in Safe Mode, installed completely fresh Firefox - it didn't help...

Helpful?

more options

Still no solution. I tried reinstalling again - no change. Just in case - I have created a new profile - how do I share it with you without a password?

Helpful?

more options

You have not said if you started the computer in Safe Mode.

Helpful?

more options

Hi. I did in this reply but maybe it was not very clear that I restarted the Mac in Safe Mode:

Danas said

Unfortunately nothing helped. I completely deleted Firefox with all the folders, restarted in Safe Mode, performed a clean reinstall, and nothing changed - still all Russian websites crash Firefox immediately! It might sound absurd, but I start thinking of some higher powers involved! :/ P.S. I also tried the Beta version and a previous (86.0.1) version - same result

So just to repeat the steps: 1. Uninstall Firefox with AppCleaner app (it removes any associated files). 2. Empty the trash bin. 3. Restart Mac in Safe Mode. 4. Install Firefox, run it without any profile. 5. Uninstall Firefox and install an older version 86. 6. Uninstall Firefox and run a Dev/Beta Firefox (it didn't require any installation) 7. Cry my eyes out :'(

I have also searched for any traces of Firefox on my hard drive and tried to delete them, however some system files cannot be deleted, and I am not sure which ones are safe to delete completely. On Apple Discussions forum it was suggested that there might be some hidden ancillary files left, but I don't know where to search for them...

Helpful?

more options

FredMcD said

Please provide a public link (no password) that we can check out. No Personal Information Please !

Helpful?

more options

Can you please tell me how do I share a public link to my profile? Where is it? I know where my profile is on the harddisk, but I don't understand how do I provide a link?

Helpful?

more options

The link(s) you are using to go to those websites. Post some of them here in this forum.

Helpful?

more options

For example: https://yandex.ru https://portal.itgen.io/ https://tvrain.ru

these are just some random examples of different Russian language websites...

Helpful?

more options

I had no problem with those links. I called for more help.


Basically, an OOM (Out Of Memory) means the system is having issues with the RAM.

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

https://support.mozilla.org/en-US/kb/firefox-takes-long-time-start-up

https://support.mozilla.org/en-US/kb/quick-fixes-if-your-firefox-slows-down


MemTest LAST UPDATED : 12/04/2020 Could you please run a tool from http://memtest.org/ in order to check the integrity of your RAM?

You will need a thumb or disk drive to install it on.


Do you let Windows handle the page file or did you set a fixed size ? Control Panel -> System -> Advanced -> Performance -> Settings

If you use a fixed size for the page file then try the former and let Windows handle the page file. How to determine the appropriate page file size for 64-bit versions of Windows {web link}

Helpful?

more options

As I said - I'm on a MAC I know that all these sites work properly - the problem is ONLY on my Mac and ONLY on Firefox. Everything else works fine. I also have Windows installed on this machine and it also works great. We also have 2 other Macbooks at home and they all work great too. None of these articles help, as I've already gone through those steps numerous times. The only thing I didn't try is installing a fresh copy of OS High Sierra, because I have no idea where else to look - but this is the last thing I will do really... I will try running the memtest later and let you know.

Helpful?

more options

Try to disable Accessibility Services in Firefox.

Helpful?

more options

Hi I ran memtest through the night - no errors I tried also disabling Accessibility Services, but that didn't help either... very strange

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.