Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem seeing imported accounts and passwords

more options

Hi there,

I have a fresh installation on three different PCs. On the first I installed, I created my account and then did an import of all my stuff from Chrome, but for the accounts and passwords it keeps saying I need to enter my Primary Password, which I haven't set. If I click on the button to login (I am already logged in), that ribbon goes away and leaves me in the passwords section showing that no accounts have been imported. My bookmarks were successfully imported.

I then tried to do this by exporting a csv from chrome and importing that, it seemed to import OK, and then the tab crashed, result no import of passwords.

I then entered in safe mode, did the import of the csv and it worked! I could successfully login to my usual sites using the stored information. However, when I exit and enter again normally, it tells me there are no accounts and passwords stored (confirmed by the fact that opening any site that I have an account on has no autofill, etc.).

I have also installed on two other PCs and synched, and on those I CAN see my accounts and passwords when launching normally. It is just the first PC that I installed on that is giving me the problem.

Remember, this is a fresh installation, so there are no add-ons.

Any idea what I can do to get my passwords to work in a normal activation and not just in safe mode?

Thanks

All Replies (2)

more options

Try to rename/remove logins.json and key4.db in the Firefox profile folder to start with fresh files and import the CSV file again.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Thank you. Just as you were replying, I managed to solve it. I decided I would uninstall and try again, but when I went to uninstall it gave me the option to "Refresh", so I did that and when it came back I now had my accounts/passwords visible.

No idea why they weren't available, but all looking good now.

Thank you so much for replying, as I'm new to Firefox I'm sure I'll need help at some other point!

Regards

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.