Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Two-Sided Print Suddenly Flips Pages "Up" Instead of "Over"!?

  • 3 replies
  • 1 has this problem
  • 10 views
  • Last reply by jscher2000

more options

Recently two-sided printing has started to flip pages "up" instead of "over" as desired. The only way I've found to prevent this is to first set the magnification and then determine the desired page range in the FF print dialog. Finally I go to "Print using system dialog...", where I can change this setting back to "over." The change does not persist, however, and must be reset every time I print, which is a real pain!

I checked the Windows printer preferences and verified that the setting saved in my default print shortcut is "over," so the change isn't coming from there. What next?

Details: Windows 10 (1909), HP Universal Printing PCL 6 (v6.9.0), FIrefox 86.0 (64bit). -- jclarkw

Chosen solution

You can try turning two-sided printing off and on under "More settings" to see whether that forces Firefox to re-read your preferred setting:

Alternately, you can fix it manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste duplex and pause while the list is filtered

Firefox should list the print_duplex value for each printer. Printers you have not yet used in the new print experience will have a weird number that is not on this list:

  • 0 => print single-sided
  • 1 => print double-sided, with long-edge (portrait mode left-right) binding
  • 2 => print double-sided, with short-edge (portrait mode top-bottom) binding

To edit a value, double-click the current value to display an editing field. Change it as you wish, then press Enter or click the blue check mark button to save the change.

Does the correction from 2 to 1 work and does it stick?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

You can try turning two-sided printing off and on under "More settings" to see whether that forces Firefox to re-read your preferred setting:

Alternately, you can fix it manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste duplex and pause while the list is filtered

Firefox should list the print_duplex value for each printer. Printers you have not yet used in the new print experience will have a weird number that is not on this list:

  • 0 => print single-sided
  • 1 => print double-sided, with long-edge (portrait mode left-right) binding
  • 2 => print double-sided, with short-edge (portrait mode top-bottom) binding

To edit a value, double-click the current value to display an editing field. Change it as you wish, then press Enter or click the blue check mark button to save the change.

Does the correction from 2 to 1 work and does it stick?

Helpful?

more options

jscher2000 -- Thanks! Your manual alternative worked perfectly! (I didn't try the other.)

Any idea what I might have done to mess up this setting? Perhaps it happened during a recent FF update? -- jclarkw

Helpful?

more options

I don't know what happened when Firefox read the duplex orientation out of the printer driver in Firefox 85. It can read it correctly in Firefox 86, but might not do so unless you change to single-sided for one cycle.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.