Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dumb sync

  • 5 replies
  • 1 has this problem
  • 11 views
  • Last reply by jscher2000

more options

Deleted previous account, created new.

Idiotically, I can access new account in Chrome but not in FF. FF continually displays deleted account email address despite clearing cache, and when I attempt to "use a different account" - the new active account - the result is as in the screenshot. It does not accept the address.

Attached screenshots

Chosen solution

Jason said

So GoDaddy doesn't think that domain is registered, does it? LOL I registered it a year ago. I have a website with this domain. I receive replies using that email address. And have look at the screenshot.

So all is good now? (There was a typo in your original screenshot -- r was missing from natural. That was the domain I checked.)

Read this answer in context 👍 1

All Replies (5)

more options

For the old email address suggestion, if it appears in a drop-down after you type a few characters or press the down arrow key, try arrowing down to it and pressing the Delete key (or Shift+Delete) to remove the suggestion.

For the new email address, GoDaddy doesn't think that domain is registered:

https://www.godaddy.com/domainsearch/find?domainToCheck=natualblood.co

If you plan to register it later, I recommend that you set up your mailbox first, otherwise the verification message will bounce and block your account.

more options

So GoDaddy doesn't think that domain is registered, does it? LOL

I registered it a year ago. I have a website with this domain. I receive replies using that email address.

And have look at the screenshot.

Modified by Jason

more options

Chosen Solution

Jason said

So GoDaddy doesn't think that domain is registered, does it? LOL I registered it a year ago. I have a website with this domain. I receive replies using that email address. And have look at the screenshot.

So all is good now? (There was a typo in your original screenshot -- r was missing from natural. That was the domain I checked.)

more options

I take everything back. I'm dumb. Must've been a blindspot... I just didn't notice the missing 'r'.

Thank You

Is there a way to delete the question? because it's useless to everyone.

Modified by Jason

more options

I think you could ask an admin? I'll flag the thread.