Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trying to rid browser of some items

more options

When opening a new tab and clicking inside the address section, there are sites that come up such as YouTube.com, Twitter.com, Facebook.com, Reddit.com.

I want to rid my browser of all of these options.

See picture attached.

How do I remove these so they no longer show?

Attached screenshots

Chosen solution

If instead of getting an automatic list dropping down you prefer for Firefox to hold off on suggestions until you start typing, you can disable the Top Sites list from appearing in the drop down using a different setting on the Options page.

Options page > Privacy & Security panel > Address bar section

Uncheck the box for Top Sites:

Read this answer in context 👍 1

All Replies (6)

more options

When you click in the bar, Firefox displays your first 8-10 Top Sites from the new tab page (AKA Firefox Home page). To manage the list, see the steps in this article:

Customize the New Tab page

Each tile has a menu button that appears when you hover it. If there is an item you can't get rid of, let us know more details about it.

Helpful?

more options

I don't have that bar with those sites in the middle of a new tab page.

Helpful?

more options

Here are my settings for new tab.

Helpful?

more options

Okay, you do need to tick the box for Top Sites on the Options page in order to show that panel on the new tab.

Helpful?

more options

Chosen Solution

If instead of getting an automatic list dropping down you prefer for Firefox to hold off on suggestions until you start typing, you can disable the Top Sites list from appearing in the drop down using a different setting on the Options page.

Options page > Privacy & Security panel > Address bar section

Uncheck the box for Top Sites:

Helpful?

more options

Okay, I had to change the New Tab setting to "Firefox Home (Default)". Then I had to enable "Top Sites". Then I had to open a new tab. Then I dismissed all those items such as Facebook, YouTube, Twitter, Reddit. Then I disabled "Top Sites". Then I set new tabs to "Blank Page" (as was before). Now those items do not show when I open a new tab and click inside the address bar. Thank you for your assistance @jscher2000.

Modified by sgtparkhurst

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.